Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1987 300 SDL
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hi All
I've got a 1987 300SDL ( my daily driver )

I'm hoping that someone has an idea on this very odd situation..

Things that don't work:
Full beam headlight flash, (when you pull the stalk towards you) Full beam does work when you push the stalk away to turn it on when you have your lights on.
No electric window, Sunroof does work
Rear window defroster, the light on the switch comes on, but won't stay on.
The window wipers don't work on any speed or wash the windows.

I've check all the fuses under the hood in front of the drivers door.
Do all these have common fuse I missed or something else.

Thanks for all your help.
 

·
Registered
Two '87 570SECs, one '87 560SEL
Joined
·
4,443 Posts
Fuse number 7 controls all of that. Pull the fuse and look at it. My friend's SEC had the same problem and the brass fuse was broken, not "blown". In the holder, the ends were close together and looked fine. Pulled the fuse and the two brass pieces fell away. If you have a gray fuse (not brass), then it could have a bad contact in the fuse holder. Replace it.
 

·
SuperModerator
1986/1990 W126
Joined
·
13,419 Posts
Yeah swap out all the fuses, preferably for the better brass or copper tipped type. Clean all the contacts in the fuse box while you're there. Dissimilar metal corrosion occurs eventually with the normal type of fuse and then gremlins happen.
 

·
Moderator
1991 500SEC sub 50K mi. 1987 560SEC Now 150K mi. 2018
Joined
·
4,029 Posts
Great advice above regarding the fuses....

Here's a fuse list in case you might require one.

Good luck.

M

Screen Shot 2019-11-19 at 7.25.22 AM.png
 

·
Registered
1987 300 SDL
Joined
·
3 Posts
Discussion Starter #5
Great advice :) thanks for a fast reply. when i get a chance to try the fuses I let you know the result.
 
1 - 5 of 5 Posts
Top