Mercedes-Benz Forum banner
1 - 6 of 6 Posts

·
Registered
2000 ML320
Joined
·
39 Posts
Discussion Starter · #1 ·
Started about a week ago. Had the ML running in the driveway....then stalled as i was ready to leave. Tried to restart many times with tno luck. Kicked over about an hour later like nothing ever happened. Drove it all week, put over 400 miles on it since it stalled....doing great i thought.

Then last night it happened while driving, come to a stop sigh and went to take off....and she dies. Same thing like before....tried to resart many time with no luck. Kicked over about an hour later like nothing ever happened. But it then happened about a 10 minutes later just a mile from my house. Kicked over about an hour later....took me close to 3 hours to go 10 miles.

Its now in my driveway and i dont dare take it out....any thoughts?

FWIW....its a 2000 ML320 w/150k miles.
 

·
Outstanding Contributor
2006 ML500 2002 ML320
Joined
·
17,655 Posts
There are a few things that mimic this problem, but it sounds like a faulty Crank Position Sensor. Try and duplicate the no start problem, and the next time it does not start watch the tachometer needle and see if it moves. If it doesn't it is a VERY good indication that your CKP sensor needs replacement.
 

·
Registered
'08 Acura MDX
Joined
·
3,108 Posts
could be the fuel pump
 

·
Registered
96' C220
Joined
·
1,275 Posts
MAF or CPS?

The Mass Air Flow Sensor will cause stalling and other crazy intermittant symtoms as well. If the car HAS to cool down to restart (as yours seems to be) It is almost for sure the CPS. There not too expensive, and fairly easy to replace yourself.

43sqd has a great troubleshooting idea there!

Good Luck!:thumbsup:

C as in 220
 

·
Registered
Joined
·
74 Posts
Had the same exact symptoms with my ML. First I changed the air mass sensor because it needed it (obd II scanner), next I changed the CPS sensor (about $130) from the dealer. There are some excellent post about replacing it yourself.
Good luck.
 
1 - 6 of 6 Posts
Top