Mercedes-Benz Forum banner
1 - 20 of 28 Posts

·
Registered
W140 S300DT
Joined
·
15 Posts
Discussion Starter · #1 ·
Suddenly the rain sensor of my W140 doesn't work anymore.
Anyone has suggestions what could be the reason?
If put in position 1 it keeps whiping. Normaly when the window is clean and not raining it stops automaticly.

Greeting from rainy holland.
 

·
Registered
Mercedes S500 - W140 && S500 W220.
Joined
·
821 Posts
Suddenly the rain sensor of my W140 doesn't work anymore.
Anyone has suggestions what could be the reason?
If put in position 1 it keeps whiping. Normaly when the window is clean and not raining it stops automaticly.

Greeting from rainy holland.
Here you go Holland buddy...
 

Attachments

·
Registered
W140 S300DT
Joined
·
15 Posts
Discussion Starter · #6 ·
Dear Salman108, i know how a rainsensor works. Only mine is not functioning anymore!!
Can somebody tell me what could be the reason.
Electrical problem? Or something else?
Did someone have the same problem?
Is there a fuse for the rainsensor?

Hope somebody has a solution that can solve the problem.

Greetings from holland.
 

·
Premium Member
'97 CL600
Joined
·
3,168 Posts
I would guess that one would have to run a diagnostic to find the problem. I have a fairly new windshield but my system will not engage except manually. Since if rarely rains here in the desert, this is not one of my top priorities.
Anziani
 

·
Premium Member
'97 CL600
Joined
·
3,168 Posts
It is about the diameter of a cigarette and is in the outside glass near the rear view mirror. It is very hard to see. There is a compartment in between the windshield and the rear view mirror that houses the connector. At least on my '97 CL500
Anziani
 

·
Registered
99" CL500 , 99' CL500, 97' S500, 01' S500, 02’ G500, 09’ G550
Joined
·
2,158 Posts
I need some assistance on this... My rain sensor works only if I push the entire plastic enclosure closer to the windshield... in other words, if I turn it on it will not work... when I put my hand on the housing for the sensor under the rear view mirror and push it (very slightly) towards the glass, it turns on and works perfectly... any ideas? can I adjust the rain sensor housing?
 
1 - 20 of 28 Posts
Top