Mercedes-Benz Forum banner

1 - 7 of 7 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi Folks,<br>
I was driving my 2002 CLK 430 yesterday when all of the sudden, all radio controls stopped working except for the controls on the steering wheel. That meant no volume control, changing to CD mode, advancing discs in the changer, etc. from the head unit in the dash. <br>
<br>
Has anyone ever had this happen before??<br>
<br>
Pls advise. The car only has 650 miles on it.<br>
<br>
Hope you can help.<br>
Thanks,<br>
Robert
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Yep, happens a lot on the CLK line. Turn off ignition and all's well again.

It's not what you'd expect from a Mercedes, but it's what you have to live with with a Mercedes. :)
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Re: Yep, happens a lot on the CLK line. Turn off ignition and all's well again.

Unfortunately, I've tried turning off ignition, letting car sit and anything else I can think of aside from pulling the fuse (I had my hand on it).<br> <br> No progress. Looks like I'm calling the dealer.<br> <br> Rob
 
1

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I was just wondering you guys... Im about to get my CLK in 2 weeks... Im really excited here... but just wondering.... im new to this German car club as you could tell on my e-mail address... crossed over from Imports to German Imports...:)... one thing that has me worried.... I see that many of you guys talk about electrical problems w/ the clk or squeaks... Cant you just go to the dealer and YELL at them for this lousy stupid problem? and tell them...heck I spent 55k and up for a good car... shouldn't have this kind of stupid defects. FIX IT and thats that.
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Looks like a defective radio or wiring problem. Bring to the dealer to have them check up.
 

·
Registered
2002 CLK430
Joined
·
64 Posts
My 02 CLK430 has been at the dealer for 8 days due to a similar problem (not the first time its been in the shop for this). They say it is a problem with the fibe optics and the signal not getting through. It is an intermittent problem with the phone/cd/radio and sometimes starting the car again works, sometimes it doesn't. It's very aggravating. Your dealer should be aware of the problem - my dealer said there have been technical service bulletins on it. Good luck.
 
1 - 7 of 7 Posts
Top