Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
2003 E320 4Matic wagon Bordeaux Red/Tan
Joined
·
15 Posts
Discussion Starter #1
So my 2003 E320 4Matic wagon has an odd trouble.

The radio buttons, all the buttons including power off/on, do not function. But the radio display functions, the radio plays, the steering wheel controls allow me to change volume and station on the FM band the radio is stuck on.

What's wrong? How do I fix this? I will not spend the money to replace the unit at the dealer unless it's dirt cheap. Not expecting that...

Is there something to reset? What could cause this behavior?

Thank in advance for answers!
 

·
Registered
00 e430 sport
Joined
·
15 Posts
I don't know what causes it but I had the same problem. I was told to either enjoy the steering column buttons and just listen to the radio or switch out the entire deck. I upgraded and replaced the deck. The steering wheel buttons do not work anymore neither does the cd changer in the trunk. I was unable to even take out the cd holder from back there. The new deck that I have (Kenwood try looking at crutchfield) has an adapter for like 70 bucks to get back those controls I just haven't gotten it yet.

I do have my old deck (the MB one) so if anyone has any helpful hints I would like to hear them as well although I am very happy with my replacement.
 

·
Registered
99 E430, 01 E430 Sport, 00 SL500
Joined
·
3,266 Posts
Is your car W210? I thought W210 ended in 2002 to become W211 in 2003.
The buttons that don't work must share a common ground that's usually fed through a ribbon cable from the front to the circuit board inside. If you can remove the whole unit, re-seating (remove, re-insert) the ribbon cable is the first attempt to fix the problem. A Q-tip with some rubbing alcohol can help clean the contact points on the ribbon cable.
 
1 - 3 of 3 Posts
Top