Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 06 CLK 350. Last week the radio just up an quit. The display says NO CDC when I try to use it and the internal single disk pretends to play with no sound. Has anyone else seen this?

Last year, the radio had to be replaced cause the radio literally went dead. This is making me a little concerned as I am almost out of warranty.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
The morning after I posted this, my battery was dead and the road side assistance came out an jumped the car. The explanation for the battery drain was that the computer did not shut down. I took it to the dealer right after and twice on the way there the ESP program malfunctioned making me pull off to the side and restart the car.

After several hours, the solution for all my problems was to do a flash upgrade to the computer. I never thought I would have a problem in my car that was purely a software issue. :)

Everything is great now.
 

·
Registered
2006 CLK 350
Joined
·
1,133 Posts
Which computer?

Wow! how many miles do you have on your car?

I haven't seen that problem yet.. and hope I never do. What is the build/ manufacture date of your car? Mine is 9/05.

Which computer are you referring to? Is it the NAV? or the Radio /CD screen? or the engine computer (ecu)?

Do you have Keyless GO? When you turn off the engine and then open the driver's door, the audio (radio or CD) is suppose to shut off and the screen goes blank. Did your's stay on during the malfunction?

Is there a service bulletin out for this problem? If so, I like to know the number.

Thanks... :)
 

·
Registered
2005 CLK 500, 2000 Honda Civic, 2000 Ford Taurus Purple Stationwagon
Joined
·
60 Posts
I've had a similar problem with mine. Sometimes the stereo will turn down on its own, like it hears the people I'm driving by complaining about the volumn. And it won't let me turn it back up until I completely restart the car. I have some subs installed, but I don't think thats the problem. Anyone else having this issue?
 

·
Registered
2006 CLK 350
Joined
·
4 Posts
I have a 2006 Clk 350..radio was working perfectly until I had the volume up high and all of a sudden it went low..now I can't get the volume back up to high??..any recommendations or similar problems?..everything works fine just can't get the volume up..please help!
 

·
Registered
2006 CLK 350
Joined
·
4 Posts
Yea i have the same problem..i can't turn the volume up high again..did you fix that issue or have a answer on how I could fix mine?.thanx bro
 
1 - 6 of 6 Posts
Top