Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Can someone please tell were the FUEL PUMP RELAY is on the car.
Got the part but cannot find were it goes, please help if you can.
Rob
 

·
Administrator
1998 Pano SL500; 1993 SL500; 2005 ML270cdi
Joined
·
8,759 Posts
It's the green relay above the battery in the boot.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
The code that came up is = 14-2 fuel pump relay(circuit 87) not working.
The 14 port on the 16 pin electric part in the engine bay is for , continuous fuel injection system(mass controller).
The mass module is big money and i do not want to change that if its another fuel relay.
The part number for my car 001 542 0219 and it says its a fuel pump relay. Everyone says its in the boot ontop of the battery but i cannot find it. There are loads of electric there and the fuel pump is just infront of the wheel next to where the battery is. Maybe i got to have another look.
Its just doing my nut in.
If the code coming up says fuel pump relay there must be one in the car somewhere?
Thanks
Rob
 

·
Outstanding Contributor
R129 500 SL 1991
Joined
·
966 Posts
If you have 119.960 engine, the fuel pump relay is part of the MAS module. Post Sept ‘92 the 119.978 used a separate fuel pump relay, which is located next to the battery.

Pull the relay and clean the contacts. Otherwise there are plenty of cheap/working MAS modules available in the US from scrapyards for around 80 bucks.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
My engine is a 119.066.
Will pull the mas module and give it a clean. There no relay in the boot?truck.
Just pulled away and the ASR light came on BUT the car would not go. It would start but as soon as you put your foot down ASR back on but no moving.
Thanks
Rob
 

·
Outstanding Contributor
R129 500 SL 1991
Joined
·
966 Posts
...
Just pulled away and the ASR light came on BUT the car would not go. It would start but as soon as you put your foot down ASR back on but no moving...
I don’t think it is not normal for the ASR dash lamp to be on without the ABS lamp as well. Does the ABS dash lamp come on when you turn the ignition key to second position, and then turn off after starting the engine?
 

·
Outstanding Contributor
R129 500 SL 1991
Joined
·
966 Posts
The code that came up is = 14-2 fuel pump relay(circuit 87) not working.
The 14 port on the 16 pin electric part in the engine bay is for , continuous fuel injection system(mass controller).
Did you scan with engine running? At least for the engine control systems the codes are stored in volatile memory on these early pre OBDII systems, so they reset when you turn the engine off.

Scans should be done while engine is running if possible. Otherwise a number of ‘false’ codes will be reported and are usually associated with the loss of crankshaft position sensor signal (port 8, code 17), which can then lead to other codes such as port 14 - Continuous Fuel Injection System (MAS Controller), typically code 11 A/C compressor engagement signal missing (circuit 87Z).
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Dude, your chassis is WB 129.066, and your engine is M 119.960.
Dude, your chassis is WB 129.066, and your engine is M 119.960.
DUDE, never been called a dude by another english man, what happened to MATE? You been there too long,lol.
Did put the numers down wrong,m119.066, is this the chassis or the engine number. On MB site this is my engine Dude, Sorry Mate.LOL. Life to short not to laugh...
Think i know the problem. The brit forum help me hopefully.
My car has no Fuel pump relay in the boot its in the mas module. The problem is wheel speed sensors making the ASR come on.
Use a blink code reader because that all you can get for a 1990 550sl, it tell you to have the car not running when you use it But have the key turned to 2. Clear that code 10 times but will try with the engine running.
Rob
 

·
Outstanding Contributor
R129 500 SL 1991
Joined
·
966 Posts
Assuming that the ABS lamp is operational, usual suspects would be worn/incorrectly adjusted throttle linkage or faulty R25 position potentiometer (the tracks wear out). The ABS lamp would normally light up along side the ASR lamp if a wheel speed sensor is faulty.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
ASR is the only light that comes on. Its doing my nut in. Going to have a good look at the throttle linkage and go from there.
Thanks for your help.
Rob
 

·
Outstanding Contributor
R129 500 SL 1991
Joined
·
966 Posts
There is a simple modification that can be made to the throttle linkage as a workaround to some ASR problems. Check out the following link:-
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
Read the Trinidad post and he never got the the bottom of it but there are a few clues.
Bloke who front brakes told me a cable had a slitt in it last year and he just put black tape on it. Horefully its the wheel sensor. Will let you know this week. Family in the way just now.
Rob
 

·
Registered
Joined
·
9 Posts
Discussion Starter #16

My ASR problem is still the but the link above might be my way out. took him 2 years.
Rob
 
1 - 16 of 16 Posts
Top