Mercedes-Benz Forum banner

1 - 20 of 40 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Hi Everyone.

So I have had a bit of a week with the car sadly !

So when I first got it the alternator pully was seized stuck so replaced the pully and belt. since then its been all good.

However driving back from my grandparents care home, 180miles away the battery light came on, no power steering and engine creeping into the high temps ! so pulled over and looked under the hood to see the belt had shredded!

Ok, so new belt ordered and fitted drove it about town and all of a sudden lost power steering again and the batter light came back on. what now ! looked under the hood and looks like the belt just slipped off. had the tools in the car luckily enough so fitted it at the side of the road, happened again ohh starting to get annoyed now so got it home and been driving the other car.

My question is what do you guy think it may be ? looking at the pully's they are all fine not excessive movement etc. I have attached a few pictures let me know what you guys think. Looking at it yesterday I think it might be the idler pully that's sticking out, how would I get this aligned correctly ?
2602989
2602990
2602991
2602992
 

·
Registered
Joined
·
6,617 Posts
Hi Everyone.

So I have had a bit of a week with the car sadly !

So when I first got it the alternator pully was seized stuck so replaced the pully and belt. since then its been all good.

However driving back from my grandparents care home, 180miles away the battery light came on, no power steering and engine creeping into the high temps ! so pulled over and looked under the hood to see the belt had shredded!

Ok, so new belt ordered and fitted drove it about town and all of a sudden lost power steering again and the batter light came back on. what now ! looked under the hood and looks like the belt just slipped off. had the tools in the car luckily enough so fitted it at the side of the road, happened again ohh starting to get annoyed now so got it home and been driving the other car.

My question is what do you guy think it may be ? looking at the pully's they are all fine not excessive movement etc. I have attached a few pictures let me know what you guys think. Looking at it yesterday I think it might be the idler pully that's sticking out, how would I get this aligned correctly
In your profile you have ML320. This looks like ML270.

Tensioner is not aligned with rest of belt train. Belt is riding off of it. What was the story with seized alternator pulley? Is this the kind with decoupler?
 

·
Registered
Joined
·
71 Posts
Discussion Starter #3
In your profile you have ML320. This looks like ML270.

Tensioner is not aligned with rest of belt train. Belt is riding off of it. What was the story with seized alternator pulley? Is this the kind with decoupler?

Oh yeah forgot I need to change that. Thanks for pointing that out.

So the belt is riding off the tensioner however I think this is because the idler pully is pushing it over. As you can see on the last photo the belt is starting to ride off this pully.

Is it easy enough to replace both tensioner and idler pully ?


So the deal with the alternator pully was, the pully its self actually spun off the shaft, the clutch pully had seized so had to replace this, now its spinning fine. Does anyone have the dimensions that this should sit at ?

I will be putting a straight edge across everything later today just thought I would post the pictures and see what people think first.

Thanks for your help
 

·
Registered
Joined
·
6,617 Posts
With new forum software best way to show your vehicle is to add it to signature. Include model year and model designation (163.xxx). I helps with parts lookup.
 

·
Registered
Joined
·
351 Posts
The idler pulley does look off, have you tried to tighten it down. Maybe it somehow got loosened with the alt issue.

If it does need changing though not for a 270 here is a video link, you should still be similar.


I love these guys even though they may not torque things.

Also you did double check that you have the correct belt length?
 

·
Registered
Joined
·
71 Posts
Discussion Starter #6
The idler pulley does look off, have you tried to tighten it down. Maybe it somehow got loosened with the alt issue.

If it does need changing though not for a 270 here is a video link, you should still be similar.


I love these guys even though they may not torque things.

Also you did double check that you have the correct belt length?
Thanks for that, I will try and tightening this up and see how it goes. Nah videos are always good even if its not exactly correct.

I went to our local store, Andrew watts gave them the vin no. and he gave me the appropriate belt to match.

PS also updated my account and should have put the cars in the signature too :D
 

·
Registered
Joined
·
269 Posts
You say "local store"... If by chance you bought a Dayco heavy duty belt, that could be your problem.. I bought one, which I had problem keeping it on.. It seemed way too stiff.. I replaced/exchanged it with a cheap-o thin belt.. It been a good 6 months and had zero problems with the "thin" belt...
 

·
Registered
Joined
·
71 Posts
Discussion Starter #8
You say "local store"... If by chance you bought a Dayco heavy duty belt, that could be your problem.. I bought one, which I had problem keeping it on.. It seemed way too stiff.. I replaced/exchanged it with a cheap-o thin belt.. It been a good 6 months and had zero problems with the "thin" belt...
Hi Bobby

so I got a contental belt so :/ not sure but I did have a cheap belt, cant remember the make but that did last for a good 6 months or so since I first fixed the alternator etc.

I wasn't able to check it last night due to the rain but will be looking at it tonight. do you think just tightening the idler pully should do it along with checking the tensioner for play ?
 

·
Registered
Joined
·
269 Posts
The problem I was having with the Dayco HD belt was: it was so thick when you tried to rap it around the "small" alt. pulley, the outside circumference was much shorter than the inside circumference .. Try this, take belt completely off... rap belt completely around alt. pulley.. Does it have a nice relaxed fit or is it trying to spring open to only fit half of the pulley.. I also noticed the the HD belt was above all the pulley rims.. the thin belt is dead on flush with the tops of the pulley rims.. This may or may not be your problem, but if you can't find anything misaligned .. it's something to consider
 

·
Registered
Joined
·
351 Posts
Bobby interesting you mention this. My daughter and I changed the belt on the 350. I went for a higher priced belt, gates I think. It has been fine but it did take the 2 of us to get it over the last pully. At one point we took it off and compared inside length to the old, that's how tight it was, it matched, never checked the outside LOL.

ABCDeScott try tighting the pulley, it can't hurt.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #11
Bobby interesting you mention this. My daughter and I changed the belt on the 350. I went for a higher priced belt, gates I think. It has been fine but it did take the 2 of us to get it over the last pully. At one point we took it off and compared inside length to the old, that's how tight it was, it matched, never checked the outside LOL.

ABCDeScott try tighting the pulley, it can't hurt.
Hi guys thanks for your advice however spent some time tonight checking things.

So looking at the pulls they all look fine and are all aligned Correctly ie, using a straight edge they are all laval with each other bar the water pump I think it is. (Is this the pully on the last photo) I replying to this off my dad's tablet so tomorrow will post some more photos but tried tinting all pullies etc but still nothing. Even Turning the engine by hand it slips off after say about 6/8 rotations.

What do you gus think just replace the tensinior and see how it goes, or any other recommendations?
 

·
Registered
Joined
·
71 Posts
Discussion Starter #12
Just adding to this, only other thing I think it my be the way the belts waving .... can anyone confirm if this is the correct Part or not for the 2.7 ? part

I did message the seller before buying to confirm if it would fit and I had confirmation. Just want to see what you guys think.
 

·
Registered
Joined
·
351 Posts
As to the tensioner the springs in them can snap or I even had one where it seize ( on a ford). It should take a pretty good deal of force to hold it back. If you were able to get it on yourself with ease the tensioner may be at issue. The job does almost require two people as in the video.

Get the vin to Witek he’s a good guy and will get the correct part number.
 

·
Registered
Joined
·
269 Posts
Is it me, and my eyes are fooling me.. Those ribs on that belt don't look right.. I'm seeing flats between each rib, when it should be total a "V" What I'm seeing is: n_n_n_n_n_ vs VVVVVV
 

·
Registered
Joined
·
71 Posts
Discussion Starter #16
To look up any parts we need your VIN.
Good point ! WDC1631132A504267

In Relation to you Wallyo - true, was fitting another belt to a ford and omg it was tough ! so might just buy a tensioner and see how that goes, as it was pretty easy with my 24" breaker bar.

Bobby, nah I kinda seen that as well when I first bought it but that was just how it came, as long as the groves are there and there's some type of tooth does it matter ?

Cheers Guys
 

·
Registered
Joined
·
6,617 Posts
Take belt off and take picture straight down or straight up.

Here are part lookups for alternator pulley with one way clutch and tensioner.

2019-09-04_051928.png
2019-09-04_052829.png
 

·
Registered
Joined
·
71 Posts
Discussion Starter #18
Take belt off and take picture straight down or straight up.
Here are part lookups for alternator pulley with one way clutch and tensioner.
Thanks for that, where do you get all these ??? would love to have this.

Oh and forgot to upload these photos that I took yesterday - Sorry for the poor lighting, but hope this can show everyone what they need.

2603162
2603161

2603164
2603163

2603166
 

Attachments

1 - 20 of 40 Posts
About this Discussion
39 Replies
6 Participants
abcdescott
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top