Mercedes-Benz Forum banner
1 - 4 of 4 Posts

· Registered
92 400SE, 93 400E, 01 CLK320, 01 ML320, 98 Land Rover Discovery
Joined
·
201 Posts
Discussion Starter · #1 ·
I purchased a replacement PSE/Central Locking pump for my 92 400se and was told the old PSE pump had been replaced by a new part number. See Pic's below. I would be greatly appreciative if someone could help clarify if the new part will in fact fit. Since the "hose module" will not fit on top of the new part, do I also need this new part too?

Thanks in advance for any help.

Russell
 

Attachments

· Registered
W140 S class, E31 850Ci, XC90 Exec AWD geartronic
Joined
·
444 Posts
It will fit. You will need to buy the adaptor kit. I have posted detail on this event as i...

It will fit. You will need to buy the adaptor kit. I have posted detail on this event as it happened to my car earlier this year.[:)]
 

· Registered
92 400SE, 93 400E, 01 CLK320, 01 ML320, 98 Land Rover Discovery
Joined
·
201 Posts
Discussion Starter · #4 ·
I stopped by the MB Dealer and purchase the additional hose and connectors. Your informat...

I stopped by the MB Dealer and purchase the additional hose and connectors. Your information was priceless! The new pump works great.

A HUGE thanks for documenting your fix for the pump change.

I REALLY appreciate your help.

Russell


I found his post from w140Gill. if others are interested.

I opened the package and examined the new pump. It looked considerably different to the older one. The old pump (p/n 140.800.19.48) had 15 hoses, which plugged directly into the pump. This newer design pump had only 6 input connections.

This MOD kit consist of
about 3ft of vacuum hose
2x 6 way connectors
6x 1 way straight connectors
2x 2 way connectors
4x vacuum plugs

Mercedes Benz Bulletin fitting procedure
The newer pump (p/n 140.80.28.48) has been standardized with connections for all the various accessories. This eliminates the need for different pumps for each model. Vacuum plugs are supplied to cap any connections in case the vehicle is not fitted with a particular accessory.
The connectors on the old hoses are the incorrect gender to fit the newer pump.
The service bulletin supplied, advises to cut the old connecter off and replace with the a new connector of the correct gender The two six way connectors require you to use a 12inch length of vacuum hose between the connector and the pump.
I found that new connecters did not fit at all well on the old hoses. The problem was that the hoses we not have a big enough diameter to slip over the new connector. I tried using lubricants, and a heat gun to no avail. I gave up after a few hours trying and used one inch lengths of vacuum hose connecting between the connector and the hose.
The vacuum lines are grouped together as follows:
Clear = Vacuum supply from engine (1) to fit to a one way connector
Black = trunk handle eject/retract (1) to fit to a one way connector
Red = Rear parking aide antennae (2) to fit to the two way connector
Yellow = Central locking (6) to fit to the six way connector
Grey = Front seat lumbar (3) to fit to the six way connector with 3 vacuum plugs
White/blue = Rear headrests (2) to fit to the two way connector
Once these are all connected to the pump plug in the power and it should all start working, as it should again. Even my saggy front seats filled with air again after being out of action for some months before my pump failed outright.
If anyone has a failed pump and wants to retract a particular accessory, disconnect the clear hose and link it directly to the hose of the accessory you want to operate with the engine running. I found the useful to retract my parking aides and trunk handle, which were stuck in the 'out' position for a few weeks before the repair.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top