Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi
I'm new here on the forum, but wondered if anyone here could help me with my problem.

Inserting the engine from a 1995 C36 in my W124 300 24v. The problem is that I'm missing wires from trothlepossition contact. to the ECU. my contact has 11 pins. I'm pretty sure they will be connected into the connector No. 1 in the ECU. My ECU has pins from 4-44 + h and l. I have been told by Mercedes here in Norway, that the wiring is the same as the C280, but I can`t makes this right. Diagram from the C280 has 8 wires from the contact. (Trotthle possisition). And is located with the rest of the wiring to the engine, and end`s up in contact 2 at the ECU. Contact 2 has numbers from 50-88, but my diagram saids 1-44. It must be a wrong diagram, but havent found anyone who can find the right one.

The engine starts and runs for about 4-5 seconds an then it dies. Then i have to wait about 5 minutes before it starts again.

Anyone here who understand what I'm struggling with, and can help me?



-Stian-
 

·
Registered
A lot of performance cars!
Joined
·
25 Posts
You need to change the computer and wiring harness from the C36. Or you will need to install the old throttle body and everything else that wont match up from your old M104 engine. Then you will have to deal with fuel management issues.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
You need to change the computer and wiring harness from the C36. Or you will need to install the old throttle body and everything else that wont match up from your old M104 engine. Then you will have to deal with fuel management issues.
The right answer was Electromotive gt:)
 
1 - 3 of 3 Posts
Top