Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1995 S600 (sold)
Joined
·
1,127 Posts
Discussion Starter #1
Ever since I got this car, I noticed that the heat / AC air volume does not seem high enough out of the vents. I can hear the fan really moving when set to high, so I know the fan is good. When I switch to RECIRC, I feel and hear a substantial difference in air volume out of the vents. I decided to pull the passenger side under-dash apart to see what might be going on. I see that the flap inside the car under the passenger dash closes and opens when recirc is turned on and off. I also checked the function of the recirc flap vacuum actuator above the pollen filter. It works properly, I can see that the door moves when commanded. I'm confused. I have this feeling that there is a flap, door, or some other obstruction blocking air flow when pulling fresh air. Anybody have any ideas on this?
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
Did you look at the main inlet filter? mine has a charcole filter in it .. cleans the air on the way in .. put very slow.. nowhere near the same volume as when I switch to fresh . on the switch on your dash if the red light comes on its working via the charcole filter.. you are not supposed the have a gale blowing if you have requested filterd air...
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
Oh yes and there is a filter DEEP IN THE BOWELS of the aircon system.. requires you to dimantle most of the front of your w140 to get at it..wipers motors etc.. It might be that ???
I have a scematic of it somwhere will try to find it for you...
 

·
Registered
1995 S600 (sold)
Joined
·
1,127 Posts
Discussion Starter #4
Merc600sec - 4/21/2005 12:44 AM

Did you look at the main inlet filter? mine has a charcole filter in it .. cleans the air on the way in .. put very slow.. nowhere near the same volume as when I switch to fresh . on the switch on your dash if the red light comes on its working via the charcole filter.. you are not supposed the have a gale blowing if you have requested filterd air...
Yes, the main pollen filter (it has charcoal coating on it) is only one year old. It still looks very good. Are you saying that your car has much more air volume on FRESH air than RECIRC? My situation is that when I select RECIRC, I get much more air flow than with FRESH. With respect to the "real" Charcoal Filter, you're right. It's buried pretty deep in the car. I've been told by MB service people that it almost never needs to be replaced. It should be replaced if you smell odors when selecting RECIRC. I would also think that it's not clogged because I get such good air volume when RECIRC is selected. Perhaps air volume drops on FRESH because it has to be pulled through the pollen filter?
 

·
Registered
Joined
·
12 Posts
Hi,

I was thinking of putting up exactly the same post as you at some point. My 98 car has the same problem as yours, although I'm not sure whether output increases when the ventilation is switched to recirc mode - I'll have to check that. And we had the same problem on our 92 car - you can imagine the disappointment when I discovered our latest car had it as well...
 

·
Registered
1995 S600 (sold)
Joined
·
1,127 Posts
Discussion Starter #6
I'm beginning to think that this is the way it is, and that nothing is wrong. I did a very cool test meant to verify the proper operation of all the flaps and doors, and it does exactly what it's supposed to do. I'll look for that info, and post it in my web page.
 
1 - 6 of 6 Posts
Top