Mercedes-Benz Forum banner

Problem with antenna?

1449 Views 11 Replies 4 Participants Last post by  clomax
I recently purchased a 190e 2.6 equipped with an aftermarket Kenwood stereo system replacing the tape player. Unfortunately the power antenna has not functioned since to my knowledge. I tried to contact the store that installed the headset in the car but they discontinued installing stereo's and weren't much help. Not knowing whether or not the motor has stopped working for the antenna or if it is just related to the aftermarket player, has anyone else had this problem? I would really like to have a power antenna again. Also does anyone have a cosmetic coverup or suggestion for the 6 tape storage rack? Thanks, Chris.
1 - 12 of 12 Posts

· Registered
90 300 SE ,85 300 GD
Joined
·
1,570 Posts
plug in the back

There is a plug in the back that is for the automatic antenna. If a specific adapter was not available, I'm betting they just didn't plug it in. It is on the same fuse as your radio, so if it works you can bet the antenna plug is not hooked up.
 

· Registered
190E 2.6
Joined
·
21 Posts
Discussion Starter · #3 ·
Thanks for the info.

Would it be easier to bring it down to a car stereo shop and have them take a look or is it something that I could try and tackle myself? Given all it is is an adapter problem.
 

· Registered
CLK55/G500/E55/ML55/etc.
Joined
·
1,234 Posts
Re: It's to the right of the sunroof switch.

It's to the right of the sunroof switch.
That's funny, we all have different years with different switches.

Seems some years don't have a power antenna switch, it just works with the radio (as it should!).

Other years do have the power antenna switch (like my 1987).

It seems on your 1985, the sunroof switch is on the dash... but on my 1987, the sunroof switch is in the roof console (like it should be... OK, well I am used to it being there from my other Mercedes).

OK, I'm sorry I just got a kick out of reading this thread. Talking about all this stuff without identifying your car is kind of futile!

-s-
 

· Registered
190E 2.6
Joined
·
21 Posts
Discussion Starter · #10 ·
There is no switch, just the interior light switch.

The only switch that is on the roof is the sunroof control and the interior light. So I'm going to go ahead and say it has something to do with the harness that is connected to the player. Now back to my original question, would it be better to bring my car to an audio store and have them fix it or could I do it myself?
 

· Registered
CLK55/G500/E55/ML55/etc.
Joined
·
1,234 Posts
Re: There is no switch, just the interior light switch.

The only switch that is on the roof is the sunroof control and the interior light. So I'm going to go ahead and say it has something to do with the harness that is connected to the player. Now back to my original question, would it be better to bring my car to an audio store and have them fix it or could I do it myself?
Chris, I suggest that you take the car to an audio store or the Mercedes dealership. I think trying to troubleshoot it with you over the forum might be more difficult than it's worth, and they might be able to fix it in 15 minutes.

-s-
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top