Mercedes-Benz Forum banner
1 - 9 of 9 Posts

·
Registered
Black 2003 230 SLK
Joined
·
22 Posts
Discussion Starter · #1 ·
Ok over the week-end I instaled my new projector headlights and everything seemed fine but on my way to work I noticed a slight problem: If the lights are turned off the turn signals work just fine, turn on the lights and both turn signals come on and won't flash, hell even the warning flashers won't work if the lights are on. I drive a '03 230 SLK and the only wires I messed with durning the installation were the sidemarkers I tapped into to hook up my angel-eyes. Any ideas to what the hell is happening to me here?
 

·
Registered
'99 SLK230 sport
Joined
·
297 Posts
I had that similar problem with my '99. Since the pre fl uses a dual filament light bulb the stock OEM light housing with the stock light bulb had to be used instead of the one provided with the halo pros. But since you don't have the pre-fl, you're contacts might be sticking. Read these threads (they talk about the problamatic piting that cause the blinker relay to stick in the combination control module [CCM]):

http://www.benzworld.org/forums/r17...lk-indicator-lights-staying-possible-fix.html

http://www.benzworld.org/forums/r170-slk-class/1400230-turning-light-wount-blink.html
 

·
Registered
2002 SLK 230 1986 560SL 2008 Honda CRV
Joined
·
3,664 Posts
Twist the two red wires together and tap into the green/white wire (side marker) twist the two black wires together and tap into the drown wire.
 

·
Registered
Black 2003 230 SLK
Joined
·
22 Posts
Discussion Starter · #5 ·
No adapter was used, were would be a good place to look for one if I was to go that route?
 

·
Registered
01 SLK 320
Joined
·
48 Posts
Doesn't matter if its a pre fl or post fl, you have to use the bulb and houseing from your oem lights. You don't need the adapter(post fl), but the bulbs that came with the projectors will not work correctly for US vehicles.
 

·
Registered
Black 2003 230 SLK
Joined
·
22 Posts
Discussion Starter · #8 ·
No adapter needed, got it. I had to use the OEM turn signal housing but used the bulbs from the new headlights. When I go home tonight I'm going to use the old bulbs and see if that will clear up the problem. I've learned over the years it's always better to start off with the easiest solution first and work your way up. I'd love to jump in a time machince so I caould tell a younger, dumber me to check for a blown fuse BEFORE buying a new battery.
 

·
Registered
Black 2003 230 SLK
Joined
·
22 Posts
Discussion Starter · #9 ·
Problem solved, put the old bulbs back in and now works like a charm, thanks.
 
1 - 9 of 9 Posts
Top