Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
MY15 C400 & MY15 ML350BT
Joined
·
628 Posts
Discussion Starter · #1 ·
Has anyone seen this issue? Our truck started doing this just recently. When you brake, only towards the end of the brake cycle (i.e. when you are almost stopped) and when you add more force, the traction control warning light is coming on and you hear and feel activity going on. Traction control from my understanding is for getting traction when accelerating and not for braking, that is what ABS is for.

Does anyone have any experience with this and recommendations?
 

·
Outstanding Contributor
2006 ML500 2002 ML320
Joined
·
17,579 Posts
From what you are describing it seems to be a braking issue. You are correct in saying that the ETS system is for traction, but you also have to understand that if an individual wheel is either slipping or grabbing more than the others, it will send a signal as such, thereby telling the computer of a wheel rotation problem, momentarily illuminating the light.

See if there are any codes stored in the computer. Below is some information which might be useful. Pay particular attention to the last paragraph which seems to be what is occurring with your truck.
 

Attachments

·
Registered
Joined
·
3 Posts
I had a similar symptom. ABS would activate just as I was coming to a stop. Traction control would activate as I started going from a stop. It ended up being one of the wheel sensors. MB fixed it for about $200.00.
 

·
Registered
MY15 C400 & MY15 ML350BT
Joined
·
628 Posts
Discussion Starter · #4 ·
Thanks for your reply.

Very interesting. I had the truck today and also noticed that the problem can happen on launch as well. This problem did start shortly after having gotten the rear brakes replaced so your article makes me wonder if the pads are the culprit or the adjustment on them.

The dealer did also think that it may have to do with a wheel rotation sensor. They are getting it on Tuesday of next week to check out.
 
1 - 4 of 4 Posts
Top