Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
1992 190E 2.3L
Joined
·
101 Posts
Discussion Starter #1
Hi,

The cruise control on my 190e isn't working...any ideas as to what it could be? At least I think it isn't working. I've tried clicking the bar with Accel on it up a few times while on the freeway and taking my foot off the gas pedal. The car usually starts slowing down. I've also tried gently pushing the bar in or pulling the bar out, also to no effect.

How do you turn on the cruise control? If I am turning the cruise control on correctly, what might be causing it not to work?

Thanks,

Ron
 

·
W201, W202, W203, W204, W205 Moderator
Amethyst 2001 C320
Joined
·
1,730 Posts
Could be any one of several issues:

1. Fuse is fried
2. Speedometer cable is stretched and the needle wiggles around
3. Speed sensor is toast
4. Cruise Control lever on the steering column is toast
5. Cruise Control Amplifier is toast
 

·
Registered
190e 2.6L
Joined
·
297 Posts
You should first check your amplifier, it's the less reliable part of the system...just changed mine and now it works!
 

·
Registered
1992 190E 2.3L
Joined
·
101 Posts
Discussion Starter #4
Well, the speedometer cable does fluctuate a little on some speeds

but I also don't know where to look for the cruise control amplifier or what it looks like. Also, when people say fuse--are they referring to one of the fuses in the fuse box or is there some other relay that has the fuses?

Ron
 

·
Registered
190e 2.6L
Joined
·
297 Posts
1. The cruise control amplfier is located under the floor on passenger side. remove the rubber, remove the floor, then the plastic and it's right there, a small rectangle aluminium box with a 14 wires plug and a black relay on the right side.

2. On the fuse box, it's 12 or 14, I don't remember, but check on the cover there is one clearly identified as "Cruise Control"
 

·
Premium Member
1986 190E 2.3-16, 1992 190E 2.3, 2015 GL350 BTC, and 2020 GLS450
Joined
·
2,373 Posts
My 16v had a bad cruise control amplifier that Helms replaced July, 2008. That was the part under the passenger foot well carpet.

The symptom was that the cruise only accelerated. It never held its speed and never decelerated.
 

Attachments

·
Registered
'85 2.3-16 '99 C280 '11 GLK350
Joined
·
4,805 Posts
Lovely picture of the amplifier . . . had to squint to see it though . . . ;)
 

·
Registered
1992 190E 2.3L
Joined
·
101 Posts
Discussion Starter #8
Okay...

I'm going to check the fuses first. Since the speedometer does wiggle a little, should I assume that is the cause? Is there anyway to tell if it is the speed sensor or cruise control amplifier? Is there a way of telling when you find it whether or not it is operational?
I'm just leery of replacing it (given the $$$) without being sure whether that is the reason..

Ron
 

·
Registered
'85 2.3-16 '99 C280 '11 GLK350
Joined
·
4,805 Posts
I'm going to check the fuses first.
Good move, start with the cheap stuff first. Check your brake light bulbs too. A burned out bulb could cause a cruise control fault.

Since the speedometer does wiggle a little, should I assume that is the cause?
The key symptom is whether it bounces at low speeds, under 10 mph, is the sign of a stretched speedometer cable.
 

·
Registered
1992 190E 2.3L
Joined
·
101 Posts
Discussion Starter #10
Fixed it!

Hey everyone,

So I checked the fuses, nothing. So I went to the junkyard this morning before work and got one off of another 190e. Put it in on before leaving and tried it out on the freeway. Both acceleration and deceleration work. Thanks so much! It would have cost me a lot to order a new part and have a mechanic look at it....

Ron
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Hey everyone,

So I checked the fuses, nothing. So I went to the junkyard this morning before work and got one off of another 190e. Put it in on before leaving and tried it out on the freeway. Both acceleration and deceleration work. Thanks so much! It would have cost me a lot to order a new part and have a mechanic look at it....

Ron
Hey Ron. Which junkyard did you go to and how much did you pay? Im in Burlingame myself. Sounds like I need to try your method...my cruise control works but it doesnt stay stable....gases really hard and then slows down then slams on the gas quickly by itself. Kinda dangerous so i dont use it.
 

·
Registered
1992 190E 2.3L
Joined
·
101 Posts
Discussion Starter #12
Went to a Pick N' Pull in San Jose

Hi,

I usually go to the Pick N' Pull on Oakland St. in San Jose. Last time I was there, I saw some cruise control boxes. This time I went to the Pick N' Pull off of Alma. They actually had more parts and it looked like the 190's were not quite as savaged.

Still hate junkyards, though, as its sad to see the cars destroyed like that...but maybe I'm overly sentimental.

Ron
 

·
Registered
'85 2.3-16 '99 C280 '11 GLK350
Joined
·
4,805 Posts
Junkyards, so 20th Century . . . Recyclers, now that's the ticket!
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Oh ok. I was at Oakland St Pick N Pull. Man that place is a dump. Filled with Mexicans and it felt like I was in Mexico. went to buy a soda at taco truck and had to speak spanish cause the lady didnt speak english. We dropped off our 1992 400E there that day for it to be chopped up. Didnt pass smog and BAR took it. Thing ran awesome, zero trouble, just wouldnt pass smog and my dad got tired of playing with it. Man that V8 was awesome- 272 hp. Even the lady who drove it off kicked up a cloud of dust and rocks from the dirt lot. She had a nice grin when she walked back out.
 

·
Registered
89 190E 2.6 x2
Joined
·
1,425 Posts
Pick Your Part in Hayward is the same way. Everyone there is Hispanic, there's a taco truck, and most of the signs are in spanish as well. Last time I was there they had 5 190's, all 2.3's.
as for the BAR program, I find it kind of sad that California is crushing perfectly good cars. The way I see it, when people buy new cars, it means more money for the state, because of higher VLF fees. They keep sending me letters every other year asking me to "retire" it and buy a newer fuel efficient one. But I always tell them "no thanks". I like paying $70 a year rather than the $200 they raised the VLF fees to for new cars.
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
I hear you man on the DMV sending those letters. I was sad to see our ride going to the place where it would get crushed. Luckily my 190E- i take care of so middle finger to the state. i like my 68 bucks a year in DMV fees as well. How much did you have to pay for the used module for cruise control?
 
1 - 16 of 16 Posts
Top