Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
so on friday i got my windows tinted on my 04 c230 kompressor using what i was told was a ceramic tint. i got 35% all around except the windsheild by a company recommended to me by my mercedes dealer who had done work with mercedes before. however, i have noticed that my radio reception since then has been horrendous and my key's range is significantly shorter (i have to sometimes walk up besides the car to get it to lock/unlock.)

i have a life time warranty on it and i am planning to call him. before i got them done i had discussed the issues and was told they knew all about the radio antenna and not to get the right corner of the hatchback wet. will ceramic tint do this? or was i fooled and given metallic tint?

edit: he called it Huper Optic ceramic tint and said it was the best you could get...
 

·
Registered
Joined
·
25 Posts
its becuse the tint has metal in it and you antenna in the wires in your back window so when the metal in the tint touches the wires in the antenna it ground all the wires together. i had the same problem whe i got mine done. go to a car audio shop and see if they can do a antenna booster or something
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #3 ·
are you telling me all tints have metal in them then? i was told here and by the people that did them to avoid metallic tints and this one they were using was a ceramic tint. are you positive that it happens regardless?
 

·
Registered
My Benz: 04 S430
Joined
·
1,219 Posts
ahduke99 - 4/9/2006 11:36 PM

are you telling me all tints have metal in them then? i was told here and by the people that did them to avoid metallic tints and this one they were using was a ceramic tint. are you positive that it happens regardless?
That doesn't happen with ALL tint. YOu can still use good ole 3M and get a lifetime warranty against fading etc.. and have no problems. I am surprised a dealer would suggest using that type of tint. Maybe they recommended the shop not his tint selection.

BTW. I have tinted all of the MB's ive owned at the same shop and have never experienced this issue.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #5 ·
i just spoke with the sales rep and he told me i was the first ever to have that problem out of hundreds of coupes they've done and assured me that it had no metal in the film. he said wait a few days for it and see if it needs to dry more. if it was still bad, he said i could either get a $30 antenna booster or he'd take off the tint and refund my money. surely my radio didn't break coincidentally on the same day i got tints....
 

·
Registered
00 C-230, 04 C-240
Joined
·
468 Posts
Huper film does not have any metal in it & should not cause reception problems. It's possible that the antenna or the antenna connection was damaged during the film install.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #8 ·
i might take it by baker and see if anything is wrong. since the guy that did them has connections withb my dealer, perhaps they can get in contact with him if he damaged anything that my warranty wouldn't cover.
 
1 - 8 of 8 Posts
Top