Mercedes-Benz Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I've got an '04 W211 and have pneumatic seat issues. The pulse light just flashes with no massage function on either and the drivers seat doesn't enable you to let out the air on the side bolsters (when you press the deflate switch), so once they are blown up you cannot let them down again. I've read it on my Star and I'm getting 9250 (pressure build up not possible due to leak) and 9254 (pressure relief valve for draining opens without active overpressure run) on the pump itself and 9260 (No or insufficient pressure supply) on the each seat itself.

On doing further testing I discovered the drivers seat right hand bolster (RHD vehicle) is leaking. Removal involved removing the side airbag which requires drilling of two rivets to enable. Now got the bladder out and confirmed it's leaking so will attempt repair. I have blocked up the air pipe to this bladder and tested the entire system again but still getting the same codes on Star so I'm thinking the pump is knackered but is there a definitive way to confirm this? Also the side bolsters on the drivers seat still do not deflate (well only the left side as the other is now removed).
 

· Registered
Joined
·
26 Posts
Discussion Starter · #2 ·
Update on this I've done more digging and on following the pipework from the pump to the seats I've discovered this pipe off and blowing out air:
2643512


Anyone know what this one of three grey pipes from the pump/reservoir in the boot connect to? I know the other two connect to each front seat but the third one is a mystery!
 

· Registered
Joined
·
26 Posts
Discussion Starter · #10 · (Edited)
After more investigation the pipe pictured is actually the input pipe for the pump so any hissing I've heard was air being sucked in. I've examine the pump again and can see no issues. I'm still getting the code for air leak but cannot see where or why?
 

· Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
Code is 9250 by the way, reading STAR info it's holding pressure initially but as you use the buttons on the seats to inflate them the air starts to drop in the pump pressure reading but the pump doesn't seem to switch itself on again to replace/replenish it.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top