Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Experts, :bowdown:

I have a low mile US spec car with everything working - until today when the steering wheel would NOT move down with the switch from its maximum vertical position.

The telescoping still works smooth and perfectly from the switch, feels fine and not like some internals have broken. Mirrors are fine, no shorts or phantom current operating mirrors as I've read in some posts.

About three days ago I moved the wheel to the full up position without any issues.

When I turn off engine but turn key on (and seat belt fastened so buzzer's off), I can hear what sounds like it could be a relay operating on the RIGHT (or to the right of the wheel anyway) side of the car when I operate the switch in the Down or Up direction. I believe it's a relay I'm hearing, but it could be a jammed motor.

Can SOMEONE help me figure out how to diagnose? I have awesome mechanics, but want to try this one myself if I can, and get back my 100% functioning car!

(OK...it's not fully 100%. The passenger headrest needs the tie-wrap trick to keep teeth from stripping on the gear, and the bladders for the seat adjustments have hardened/cracked...I'll have a solution for bladder replacement soon and post the DIY here).

Thank you in advance for your help.

Steve
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
Its like a dogleg joint wound by a motor.. you might try a turn to the left or right might help free it but seems you have overreached it.. I will see if i have a diagram or drawing on my EPC.. give me a day
 

·
Registered
1986 560SEL, 1986 560SEL, 1992 500SEL, 1999 S500
Joined
·
473 Posts
The motors in he steering colum get used so infrequently that the armatures develope oxidation and the brushes loose contact with them and may seize in position. I had this happen before. The motor must be spun by hand a little. I can't remember If I pulled the motor out or forced it to rotate by pushing hard on the colum.
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
Pics

Slow down there tiger .. wait till you get the info..
OK have some pics from my EPC but they are camera shots from my lappy.. Win7 x 64 bit wont run my EPC and camera software wont run on 32 bit lappy..Plus snail speed upload today...
 

Attachments

·
Registered
1996 S320
Joined
·
75 Posts
Hi there, I have the same problem which occurred recently i removed my cluster for some fused bulbs so tilted the steering wheel down to max when i fixed everything back up again the steering refused to tilt up (was working fine before) and i could hear the motor working but no tilt! can anyone help me to remove this mechanism without opening alot of things. i removed the cluster the under dash pad could see the motor but donot understand on how to remove it.. PLZ HELP
 

·
Registered
1996 S320
Joined
·
75 Posts
hi there, Plz help i want to remove the tilt mechanism as my motor is running but not tilting which was fine before. I have removed the lower dash and cluster but cannot see any bolts or screws to take the unit out.. PLZ HELP as the steering is all the way down and giving me alot of difficulty driving
 
1 - 8 of 8 Posts
Top