Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
2002 S430 AMG wannabe
Joined
·
115 Posts
Discussion Starter #1
Hi Guys (and Gals!).

I've been in love with MBZ since I was a boy growing up in Munich (born Stateside, but grew up in BRD at the time). Owned two great cars in the 80s,.....82 300 SDL, and 88 560SEL (in AZ). Moved back to Germany in 1998, came back to the States (this time CA) in 2000, and out of US again.

Long story short,.....back in CA (this time for good, getting old, staying put, no more GI Joe games for me).

Just bought a MINT 02 S430AMG. I'm in love with the thing. 70K on the clock, and feels/looks like new. One thing DRIVES ME INSANE!!! "Teleaid SOS" warning. I HATE it. I read everything written on this site about it, and called three dealerships (and two independent) in Inland Empire, and they all told me to get lost (in short).

If anyone knows a dealer that is willing to perform this (have a printout of the Star Bulletin in hand), please let me know. I am reluctant to start driving to the dealerships at random with the bulletin in hand, and pleading with them. The closest dealership to me is about 45 min away.

I've read some old posts from a member down in La Jolla who has SDS computer and was offering this service to SoCal forum members, but I don't know how to find him (I would GLADLY drive down there, instead of dealing with snotty service "advisors")

If anyone can point me in the right direction, or put me in touch with the guy in La Jolla, I would be extremely grateful.

Thanx
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,979 Posts
Welcome to the forum, and congratulations on your new acquisition!

I know this must be one of the most frustrating things - the analog Tele-Aid is useless, completely inoperative, but dealers won't disable it because of concern over "safety" or liability issues.

As to the member in LaJolla, if he is still participating in the forum, click on his name in any of his posts; and send him a private message or an email. He may respond.

I also came across the following advice on another forum: "Call MBUSA at 800-367-6372 and they can arrange for it to be turned off." Please let us know if this works.
 

·
Registered
W209 CLK500 & W220 S430
Joined
·
320 Posts
Hi Guys (and Gals!).


Just bought a MINT 02 S430AMG.

I'm in love with the thing.

70K on the clock, and feels/looks like new.

One thing DRIVES ME INSANE!!! "Teleaid SOS" warning. I HATE it.
What does it do that could drive you insane ?

Walters wouldn't help you out ?

Red, *<:){)-
 

·
Registered
96 and 08 911 turbos
Joined
·
2,988 Posts
well, its an s430, there is nothing AMG about it.

I would see if you could get the dealer to just deactivate the teleaid. It doesn't work anymore anyways.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Anyone with SDS can do this, connect SDS and go to Central Gateway and select coding, then change teleaid from present to not present, job done.
 

·
Registered
2002 S430 AMG wannabe
Joined
·
115 Posts
Discussion Starter #6
Thanks to all that replied.

The car has the AMG "package" from the factory (ground efects, and staggered wheels, and badges). I haven't been in MBZ game since 1998, and I'm still learning about these new models. "Nothing AMG about it", huh? Thanks for the kind words sir. Sorry if I ofended your expert's mind with my post.

And regarding Walter's,.......they were rude on the phone, told me that this can not be done, and I called Fletcher Jones, (I was refered to them by MBUSA - thanks to the poster that posted their number)......Jones' people told me that my vehicle has two recalls to be performed, and they will take Teleaid message off as well. "No charge" they told me, and I have an appointment tomorrow.

And to answer the question why I hate this message,.......when I sit in the car, I want to take off BEFORE "preflight" check list (done too many of them in my career). This stupid message requires one more button to push, and I DO NOT like ANY malfunction messages on ANYTHING I drive, ride or fly. My computer display shows "1 MALFUNCTION" at all times, and I don't like it. Simple as that. I also don't like that this company has it "in" with MBZ, and can force their service (or annoying messages) on me.

I believe in freedom (and I fought and bled for it), and I don't want to be told what I can or can not do, as long as it's not against the law. So,.....combine all that (a case of OCD, 20+ years in the uniform being told what to do, and a slight annal retentive personality developed in the military), and you have the answer why I hate this message.

Thanks again to all that tried to help.
 

·
Registered
96 and 08 911 turbos
Joined
·
2,988 Posts
The car has the AMG "package" from the factory (ground efects, and staggered wheels, and badges). I haven't been in MBZ game since 1998, and I'm still learning about these new models. "Nothing AMG about it", huh? Thanks for the kind words sir. Sorry if I ofended your expert's mind with my post.
.
Well, its the sport package and the badges shouldn't be there. I'm actually not trying to be snarky. If you go around these forums telling people you have an S430 AMG, you are liable to get a far worse tongue lashing.
 

·
Registered
2002 S430 AMG wannabe
Joined
·
115 Posts
Discussion Starter #8
Sorry,

I must've misunderstood you. So educate me here pls. The AMG wheels (factory wheels with AMG logo cast in one of the spokes), and the "AMG" emblem on the trunk should not be there?

The lady I bought the car from DID NOT add those things, and I am 100% sure (saw the pictures of her taking delivery of the car 10 years ago). The picture clearly shows the AMG emblem on the trunk.

I don't like emblems, so one of the first things I did (before buffing the car), was to remove the emblems (both, S430 and AMG). Unfortunately, even after buffing, the "ghost image" of the emblems is still there. So I will put the new emblems right back where the old ones were.

And what is your take on this? How did that car ended up labeled as such? I don't think the dealer would do that. The lady took a delivery of that car in SEP 01, and she was the only owner.
 

·
Registered
96 and 08 911 turbos
Joined
·
2,988 Posts
Dealers did this all the time. They added the amg badge to cars that had the sport package. If you want to leave the badge on there cause you like it, then go for it. Otherwise, its not "from the factory" correct, but more so a dealer add on.
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,979 Posts
And to answer the question why I hate this message,.......when I sit in the car, I want to take off BEFORE "preflight" check list (done too many of them in my career). This stupid message requires one more button to push, and I DO NOT like ANY malfunction messages on ANYTHING I drive, ride or fly. My computer display shows "1 MALFUNCTION" at all times, and I don't like it. Simple as that.
As a retired USAF pilot, I thoroughly understand how irritating a warning message or light can be when you can't get rid of it. It is screaming at you that something is wrong, and you have to attend to it. You can't. And it is a distraction the whole time you see it. For those who do not fly, pilots are trained to constantly scan the "cockpit," including the instrument panel, and to be alert for any warnings or even a gauge or switch that is out of place. We may stop flying, but we don't stop being "pilots." Ever.

Actually, Tele-Aid (the company) has nothing to with your warning. The equipment in your car is a dedicated analog cell phone, usable for only two purposes: Allowing you to call the Tele-Aid subscription service if you needed them, and to report your GPS coordinates in the event of an airbag deployment. The entire U.S. analog cellular network was taken down by the government more than 2 years ago, and converted entirely to digital; the analog frequencies were reassigned for other uses (WiFi being one).

The system was designed to alert you if it encountered a malfunction - such as loss of signal, so that it could not report an airbag deployment. This can happen when one activates the system inadvertently or otherwise. Unfortunately, I don't believe the designers foresaw the loss of the analog network, and didn't provide a reliable way for an owner to turn the warning off.

Oliver, by the way, is correct on the AMG badging. While MB offered an AMG "sport package," for about $1,500, it was an appearance package - but it does not make the car an "AMG." There are other extensive modifications, mainly major engine changes, tuning, and brakes, that make up the full AMG package - which ran around $10,000. That option was never offered on the S430; only the appearance package.
 

·
Registered
2012 S550 , 2003 S55 (Sold)
Joined
·
45 Posts
Danielsand.....

I had the same issues after taking the badges off...so i wetsanded the area and polished and buffed after.....you have to look REALLY close at a certain angle to still see the shadow now.

Good luck with the car.
 

·
Registered
2002 S430 AMG wannabe
Joined
·
115 Posts
Discussion Starter #12
You guys are amazing! Thanks for all the help, you all so unselfishly offered.

Some of my concerns are solved. Thanks to the poster that posted the .pdf of the Star Bulletin regarding Teleaid SOS issue, I was able to TEACH the service department manager (some manager, huh?) how to erase PERMANENTLY the annoying message, and malfunction note. They were shocked when I produced the paper! They told me that they never heard about the procedure to take that message off, and they did not know that it would be legal to do!

Service advisor told me that they turned away 15-20 customers just last month with the same issue, and told them "IT CAN NOT BE DONE"!!

They charged me $72.50 to remove the annoying message, but to me it was worth it. Now they can call all those customers back, and offer that service to them (plus the upsale, as they always do!).

They found few issues with my "new" car though. I can take care of the transmission service, and the front brake pads, but they found a leaky "transmission connector", and I can't find what that is, or where to buy it. There are NO leaks on the floor of my pristine garage, and I wonder what this thing is, where it's leaking, and how come I can't find it on the parts websites!?

So,.....to exploit your generosity with information, ....please tell me what is it I am looking for, and where to buy it.

I wrench on motorcycles and airplanes for fun (not really,.....out of need, when they need it!), and I'm sure I can replace whatever the gizmo is.

Any help will be appreciated.
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,979 Posts
According to what I read, it could be from a bad seal at the connector; or it could be a crack in the conductor plate in the transmission. One thing you will find helpful on the W220 forum is the W220 S-Class Encyclopedia sticky toward the top of the first W220 page. The first entry under "Transmission" has information. Sorry the first poster's links are broken, I can't control that. There are other photos that may help.

One member of another forum, whose background I do not know, indicates that if it is a bad conductor plate, replacing it should be possible without having to purchase a new (and expensive) valve body. Post 14, S500 Transmission kickdown problem - MBWorld.org Forums

Tranny experts, please chime in!
 

·
Registered
Current 2017 GLE350, 2007 S550, 2002 S430, 1998 ML320 Deceased 74 240D, 92 400E, 97 E420, 13 GLK350
Joined
·
1,915 Posts
1 - 14 of 14 Posts
Top