Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
help me PLEASE i have a 1998 ml320
Due to the fact the AC is not working... I have taken it to a garage... system is fully charged !!! C fans will NOT turn on and compressor will NOT run The mechanic put tested to power wrest on compressor with AC in ON mode... there is power to compressor but fans DO NOT RUN and compressor does not come on. Mechanic thins it is a bad compressor.

Please help Thanks :)
 

·
Registered
2000 ML320, 2008 ML63
Joined
·
54 Posts
have a compressor for a 2000 ml320

hey, i have a AC New rebuilt compressor kit i bought but never used since my 2000 Ml320 broke down the same week i bought it, needs new fuel pump. kit includes new compressor, oil, and drier expansion tank. $300 is what ill offer it to you for, since its literally brand new still in the box, and by the time i get the fuel pump fixed it'll be winter and wont need it. and have you checked your fuses, maybe its blown?
 

·
Registered
1999 E300TD
Joined
·
167 Posts
Green, it is possible you have an internal problem with the compressor. The fans will not turn on until the demand is there when they are needed. There is an upated harness for your fans. In the left side engine compartment fusebox , you need to locate the 30 amp fuse that controls the fans. If its blown, there is an updated harness and higher amp 40 fuse to prevent the fans from not working again. You could have more than one problem here, you need to get the compressor on first, but I was just throwing out the fan issue there since ive fixed a few hundred of them
 
1 - 3 of 3 Posts
Top