Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
2008 C300 (sold), 1987 560SL, 2007 CLK350 Cabrio, 2011 E350 Coupe. ALL 040! :)
Joined
·
121 Posts
Discussion Starter #1
So the car looks great BUT has sat for a few months and the battery died. We jumpstarted it and it ran like a clock but after about 5 min of driving the alarm went off and was blowing driving down the road.

Went through the thread to see how to disable and got to the point where I'm unplugging the unit inside of the little door behind the glovebox but that didn't stop the clicking and the lights flashing. I unplugged the square plug but there seems to be a more rectangualr one as well? this thing looks like an ECU for the engine or something so am afraid to pull both out.. What should I do?

If there is an existing post that provides a step-by step please link me and sorry for buggin ya.


we still love her even though she is screaming at us for waking her up! :)
 

·
Registered
2008 C300 (sold), 1987 560SL, 2007 CLK350 Cabrio, 2011 E350 Coupe. ALL 040! :)
Joined
·
121 Posts
Discussion Starter #2
PS We don't have the "red dot" key! or a factory key at all for that matter!
 

·
Registered
1979 280SL, 1984 280SL
Joined
·
5,659 Posts
You don't need the red dot key to enable or disable the alarm. It is just a piece of plastic that indicates the car is equipped with an alarm. Did you follow the manual's procedure to shut it off? If I recall, you have to hold the key all the way to the unlock position- can't recall- mine is disabled.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,224 Posts
There are two plugs on the alarm module. It is the only module in there with two plugs. Pull both of them. Replacement keys from the dealer no longer come with the red dot.
 

·
Registered
2008 C300 (sold), 1987 560SL, 2007 CLK350 Cabrio, 2011 E350 Coupe. ALL 040! :)
Joined
·
121 Posts
Discussion Starter #5
There are two plugs on the alarm module. It is the only module in there with two plugs. Pull both of them. Replacement keys from the dealer no longer come with the red dot.
So the black plastic box that is say the size of a Beta cassette with a 1 squarish and 1 rectangular plug should both be pulled and the system will be disabled? Can post a pic tomrrow to confirm... thanks for your help!!
 

·
Registered
1987 Mercedes-Benz 560 SL
Joined
·
973 Posts
So the black plastic box that is say the size of a Beta cassette with a 1 squarish and 1 rectangular plug should both be pulled and the system will be disabled? Can post a pic tomrrow to confirm... thanks for your help!!
Here's a couple of pictures. The indecipherable one is from the Official Service Library's electrical troubleshooting manual, pointing out the location of the Anti-theft Alarm Control Unit, component N26.

The somewhat clearer one is from my camera. I think you've identified the plugs you need to pull, one large rectangular and a smaller square one, side-by-side, in the foreground. Best of luck with your repair, bud.

Good road,
 

Attachments

·
Registered
2008 C300 (sold), 1987 560SL, 2007 CLK350 Cabrio, 2011 E350 Coupe. ALL 040! :)
Joined
·
121 Posts
Discussion Starter #7
Goin down to try it now! You guys ROCK!! THANK YOU SO MUCH!
 
1 - 7 of 7 Posts
Top