Mercedes-Benz Forum banner

1 - 1 of 1 Posts

·
Registered
1995 SL500
Joined
·
12 Posts
Discussion Starter #1
I have had the dreaded ASR/ABS light on. went through and so far have put on a Beckman rebuild EA brand new wiring harness, rebuilt MAF. sent my modules back to Beckman and had them checked (E-gas LH Etc) they all came back as being fine. Out of total frustration i took it to an indy suggested by beckman. I am thinking finally I will know what the problem is after they diagnose it with STAR right???? WRONG, I get a call that says the CAN BUS stopped communicating all of a sudden and they dont know why. they were able to get a code 30 and a code indicating left rear wheel speed sensor and a ISC throttle position code. they reset the codes and then the CAN bus stopped communicating. The tech said he wanted to pull the casing for the modules and pinout the system to determine why the CAN isnt communicating. The tech indicated he thought based on the initial codes before the CAN Bus stopped communicating the ETA could be bad. I built an LED flasher when i check pin 6 (ABS/ASR/ICS Test Pin) I get no codes not even a single flash back, so it appears nothing is coming through this pin which I think is strange. Before changing ETA it would flash codes. The others work as they should. Any Idea what they mean by pinout the modules? how do i do this...they want over 400 to do it...could the eta be causing me to not get a reading on Pin 6? can you reset the CAN ? Thanks for any help from someone who understands this.:surrender:
 
1 - 1 of 1 Posts
Top