Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
'04 G55 '80 280GE '99 S420 '98 E320 2011 E350 2016 GLA250
Joined
·
3,093 Posts
Discussion Starter #1
I had previously replaced my engine mounts on the 1999 S420, with a marked improvement in the idle qualities.

Since I still had a VERY subtle vibration, I opted to change the rear mount, just for the fun of it.

Super easy job. It actually takes more time to get the car lifted, as it does to R/R the mount, plus, as opposed to the "expensive" front mounts, the Rear is a measly $30 bucks.

One "variation" from the WIS is that I did not REMOVE the cross-member. You can loosen it sufficiently to get the mount in/out if you minimally (1 or 2 cm) raise the transmission pan.
 

Attachments

·
Registered
'04 G55 '80 280GE '99 S420 '98 E320 2011 E350 2016 GLA250
Joined
·
3,093 Posts
Discussion Starter #4
I cannot tell a lie....

No it didn't, but it is such a SUBTLE vibration that I'm sure no one, except me, would even notice... but I'm pretty picky..
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
Ya know, reading through your DIYs makes me want to load the car with all the stuff I have to do and drive to Texas to use your facilities and meet the Rolex in person...wow, I'm not sure this is really your work, the Rolex is conspicuously absent from the pictures. :D

This is directly applicable to the 210 as well (care to ask how I know?), so thanks for another DIY those guys can use.

Take care and enjoy the ride,
Greg
 

·
Moderator
M20
Joined
·
4,793 Posts
good post G-AMG

Instead of making this thread a sticky, I will instead update the knowledge base thread first page to have a summary
 

·
Registered
1995 S 420, 2012 GLK 350 and 1997 Audi Cabrio; Previously 1982 280CE, 1974 450SL, 1974 911S Targa
Joined
·
456 Posts

·
Registered
1999 E300TD: 365,000 kms.Parked for the winter. 2002 Golf TDI, 426,000kms, winter beater
Joined
·
87 Posts
Thanks for great write-up and pix G-AMG !!

I replaced my tranny mount today, W210 E300 (1999). Procedure same as you describe, except the two bolts that attach the mount to the tranny are poorly accessible due to the exhaust on the right side, and both sides due to the mounting bracket for the plastic cover under the tranny. I found it much easier to drop the cross member, then remove the mount from the transmission.

Cheers
 

·
Registered
93 190E 2.3, 94 E320 (sold), 01 E320, 99 S320, 18 Durango
Joined
·
4,966 Posts
Thanks G-AMG. Replaced the transmission mount today and I can feel the difference.
 

·
Registered
2002 E320 SE, 2006 CL55 AMG
Joined
·
128 Posts
Just did my W210 and W215. For the CL55, you'll need a swivel 16mm or a swivel 3/8" adapter for a 16mm socket due to the exhaust. The E320 is a straight shot with straight socket extensions. I like to clean the threads before reassembly so you'll need a 10x1.5mm and an 8x1.25mm tap/die if you go that route. On mine both the 13mm and the 16mm bolts were blue so I loctite'd all four bolts. I didn't lower the crossmember like G-AMG does. You'll need to wrestle against the new rubber in the mount to get the holes to line up. I didn't want to re-loctite the crossmember.

On both my cars, the transmission was raised about 20mm after replacement. The old mounts were settled but looked uncracked.
 
1 - 10 of 10 Posts
Top