Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1996 SL500 / 2000 SL500 Sport
Joined
·
3 Posts
Discussion Starter #1
I have a 2000 SL500 Sport with about 78K on it...and the car has been a dream!

When I bought it private sale, it was from the original owner who really did not drive it daily, but had it serviced. So I figure you just need to drive them out and put in some seat time to get everything back.

The Check Engine light came on a few weeks ago, but within a two day period, turned itself off. I then made the drive to Tucson, (about 100 mi) and it never came on. It then came on again down there, but then turned off for the drive back. This morning when I got in the car to go to work, it turned on, but then when I got in the car to go to lunch, it turned off??? THIS IS THE ONLY ISSUE WITH THE CAR AND ITS DRIVING ME NUTS!!!!

Can anyone help?
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,112 Posts
Do a diagnostic scan and it will tell you what causes the CEL to come on.
 

·
Registered
2005 ml350 2001 e55 amg
Joined
·
144 Posts
When mine did this it turned out to be two of the O2 sensors had failed. It caused the check enigne light to come on and go off just as you described. The only way I found this out though was by having the diagnostic test ran on it, which is what you should do. Who knows though, it could be something else.
 

·
Registered
1996 SL500 / 2000 SL500 Sport
Joined
·
3 Posts
Discussion Starter #5
Thanks!

Thank you everyone for the response! I will definitely go run the codes. The car does not hesitate at all when the check engine light flashes on and off, but I think it is just a psychological thing when its off I feel it drives better.
 
1 - 5 of 5 Posts
Top