Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1984 500SEL EuroSpec w/ an AMG steering wheel : ).
Joined
·
223 Posts
Discussion Starter #1
I just had my transmission rebuilt. The transmission is shifting and engaging perfect. I am noticing that it's taking pushing the gas pedal half way down just to get the car rolling from a dead stop... is there anything I can adjust to get a quicker pedal response?
 

·
Premium Member
2012 CL550 4MATIC Coupe
Joined
·
9,985 Posts
Sounds like your kick down switch may need adjusting? The linkage in the back?
 

·
Registered
1985 500 SEC, 2005 E320
Joined
·
1,294 Posts
I just had my transmission rebuilt. The transmission is shifting and engaging perfect. I am noticing that it's taking pushing the gas pedal half way down just to get the car rolling from a dead stop... is there anything I can adjust to get a quicker pedal response?
sounds like the linkage bushing to me. easy to replace and cheap. they go bad about every 60k

 

·
Registered
1984 500SEL EuroSpec w/ an AMG steering wheel : ).
Joined
·
223 Posts
Discussion Starter #4
Thank you both very much! There is a lot of play where that bushing is. Can you get this bushing at autohausaz?
 

·
Premium Member
2012 CL550 4MATIC Coupe
Joined
·
9,985 Posts
Yeah, I believe he has it, or if all else fails, MB
 

·
Registered
1987 420SEL
Joined
·
1,133 Posts
Check the entire linkage at the rear of the engine; there are a few bushings in addition to the one illustrated. Make sure all the mounting bolts, most of which fasten the intake manifold to the heads, are all tightened to 25Nm.
 
1 - 6 of 6 Posts
Top