Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
2007 CLS320, 1998 E300TD estate, 2001 Ducati 996SPS, 1981 Moto Guzzi Spada
Joined
·
183 Posts
Discussion Starter #1
Have found a problem with my windcreen wiper since I changed the blade - it now doesn't clear at the edges and a patch at head-level on each side. I tried checking the wiper when stationery on the screen, and it simply fails to touch. Have I done something to the arm? The blades are Bosch Super Plus 25MB (in Uk) so are reputable.

Hope you can help.
Cheers, Steve
 

·
Registered
2007 CLS320, 1998 E300TD estate, 2001 Ducati 996SPS, 1981 Moto Guzzi Spada
Joined
·
183 Posts
Discussion Starter #3
The problem isn't so much with the length of the blade - it fits fine and I've had good results with the same before - some of the patches are way in to the main screen area - the blade doesn't seem to be touching well past half-way.
Steve
 

·
Registered
2001 E430 4Matic
Joined
·
42 Posts
It is because the new blade is pretty stiff. The factory ones usually wipe the whole windshield prefect cause they are designed for the car or have just been on so long they form to the shape they rest at. I bet if you looked at the edge the blade will not be touching the windshield just a little bit. When I put new Bosch blades on my 740i I bent the outer edge of the blade a tiny bit on the frame part. It fixed it and worked perfect after that. If you do that be careful.
 

·
Registered
2007 CLS320, 1998 E300TD estate, 2001 Ducati 996SPS, 1981 Moto Guzzi Spada
Joined
·
183 Posts
Discussion Starter #6
I had a look further, and it seems that the blade at the bottom end is jamming against the springs as there is not enough room between the arm and the screen. this is pushing the arm away from the screen slightly at the outer end. Bit odd this I thought - Is the blade simply too long and is specified incorrectly?

I think I'll have to cut away the final 1" and it should then be OK
 

·
Registered
2004 BMW 325CI
Joined
·
1 Posts
Cold weather (read: the blades seem to freeze stiff) makes my wipers act like what you describe as well...something to consider as a cause (I have no solution to offer though) if your idea doesn't prove to be a fix.

GL!
 

·
Registered
2007 CLS320, 1998 E300TD estate, 2001 Ducati 996SPS, 1981 Moto Guzzi Spada
Joined
·
183 Posts
Discussion Starter #8
Took it to mechanic. He couldn'y find anything amiss, but replaced the blade with another exactly the same & the problem cleared even though I'd just done the same! Go figure!!
 
1 - 8 of 8 Posts
Top