Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2003 ML500 Inspiration
Joined
·
245 Posts
Discussion Starter #1
Just wondering if anyone has had a problem with their passenger side mirror not returning to the exact position after tilting during reverse?

My mirror was fine, but over the past few months, the problem has gotten worse and I have to reset the mirror everything after reversing.
 

·
Registered
2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Joined
·
2,126 Posts
Have you checked to make sure that the mirror is "snapped" in place? A couple of times, I found that someone had bumped my and dislodged it. I have to manually push the housing in place (not fold it, but push it straight in, towards the truck).

Otherwise, I would wonder if there is something retarding the movement of the mirror. Perhaps it needs a good cleaning or re-lubing.
 

·
Premium Member
02 ML320 06 ML500
Joined
·
16,844 Posts
I don't have any wiring diagrams on this issue, but tomorrow I will see what I can do.
 

·
It was fun while it lasted
2002 ML320, 2005 S430 4MATIC RIP, 2010 F150 Crew Cab
Joined
·
11,130 Posts
There is a technical service bulletin on this. Right Mirror doesn't return to original position. It is very common on 2002-2004 models. I just turn mine off where it doesn't move. Move your toggle switch to the left mirror position.
 

·
Registered
2003 ML500 Inspiration
Joined
·
245 Posts
Discussion Starter #5 (Edited)
I like the fact that it tilt's down especially when parking near a curb, so I would prefer to have it working properly.

If there is a technical bulletin and is a common problem - is there a solution that won't break the bank like resetting it or something.

Everything with the mirror otherwise is okay, nothing blocking it or anything.

Thanks 43sqd - anything you can find would be welcomed and appreciated.
 
1 - 5 of 5 Posts
Top