Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
2005 E320 CDI (W211)
Joined
·
157 Posts
Discussion Starter #1
I've had this happen on more than one occasion recently. That being...the seat belt reminder chime just starts beeping. I think it is somehow detecting weight on the passenger seat, even though nobody is sitting there (an no items are placed on seat either). I can make the chime stop if I simply buckle the passenger side seat belt. Is this behaviour indiciative of a seat control module going bad? Could this problem cause a battery drain?

You may have seen that I posted about a dead battery this morning. Well...I'm just wondering if the two issues might be related. Reason I think that is because of this post - Seat Control Module (SCM) Gone bad
 

·
Super Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,145 Posts
I should not cause a battery drain.

Three things could be at play. The weight sensor which can be re-calibrated, the child
seat sensor, or even the seat belt latch. In my case the leather was too tight on the
sight and tricking the sensor. Then a few months later the seat belt latch malfunctioned.
Both were good will repairs as the car a year newer and 25k less miles.
It sounds like the weight sensor is acting up. Mine was re-calibrated for more weight
using the SDS procedure and a set of weights to 15-16kg. Factory settings are around
10-11kg. It solved the problem until the latch acted up. There are TSBs for the items
listed except the child seat sensor. There may be one on it, I just have not seen it.
 

·
Registered
Joined
·
34 Posts
Latch the passenger seat belt and see if the chim stops. If it does then the buckle is your problem. Also have the car scanned and codes should come up.
 
1 - 3 of 3 Posts
Top