Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
85 300 TDT
Joined
·
2,260 Posts
Discussion Starter #1
... how to free it? Changed over to snows and the passenger side rear was last. I did have the brake set hard when I jacked it up. Now I have a thump, thump, thump with each wheel revolution. Lugs are tight, no flat spot on the tire. What else could it be?

Had to give up for tonight, but will look at it again in the morning. Tried to free it by setting and releasing the brake while moving a couple times, no luck. Suggestions?
 

·
Registered
'89 300TE, '79 450SL, '01 ML320
Joined
·
1,051 Posts
wheel lugs correct length for the winter wheels? If they are too long
they will rub on the parking brake.


Fish
 

·
Registered
Mercedes 300te
Joined
·
1,970 Posts
Did you use steel wheels? If you did it takes shorter bolts. Like fish said. Make sure not to run it when you hear the thump thump sound..
 

·
Registered
85 300 TDT
Joined
·
2,260 Posts
Discussion Starter #4
Brilliant all! I've done this several times but in my haste yesterday I forgot to grab the bucket of lugs that came with the wheels, which are in fact, different!
 

·
Registered
85 300 TDT
Joined
·
2,260 Posts
Discussion Starter #5
All better. Many thanks to the collective wisdom of the board. Once again saved me a lot of bother and perhaps some big bucks. Remember, boys and girls, your after market wheels probably don't take the OEM lug bolts. And don't change your tires over when you're half loaded.
 
1 - 5 of 5 Posts
Top