Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1997 e320
Joined
·
3 Posts
Discussion Starter #1
Help please!
I have a 1997 E320 with 95,000 miles. I am getting a P0740 error code (Torque Converter Clutch Circuit Malfuction). The transmission seems to be operating okay (shifting fine) and the transmission fluid was changed at 50,000 miles. What is causing this code and what is the fix?
-MAP
 

·
Registered
1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Joined
·
6,019 Posts
That is

a generic code for the torque converter solenoid ,check fluid level at operating temp with the engine running in park.If you can get it on a lift make sure all electrical harnesses to the trans are hooked up and dry.Look for broken or frayed wires.Then you can erase the code and drive as normal to see if the light comes on again.If it is going bad it will show up in decreased mpg and hesitation in 4th gear.But since you say it all appears normal,clearing it may just solve the issue.If not you will have to get it on a star machine that can isolate the code more accurately then the hand held scanner.
ohlord:bowdown:
 

·
Registered
1996 Mercedes-Benz S500
Joined
·
721 Posts
a generic code for the torque converter solenoid ,check fluid level at operating temp with the engine running in park.If you can get it on a lift make sure all electrical harnesses to the trans are hooked up and dry.Look for broken or frayed wires.Then you can erase the code and drive as normal to see if the light comes on again.If it is going bad it will show up in decreased mpg and hesitation in 4th gear.But since you say it all appears normal,clearing it may just solve the issue.If not you will have to get it on a star machine that can isolate the code more accurately then the hand held scanner.
ohlord:bowdown:
what do you mean hesitation in 4th???
i have a 96 s500 and i dont really want to start another thread on this but i think our transmissions are similar? i have the 722.6, 5 spd auto.
and i got this same code? if i find my dipstick ill check the fluid level to make sure its okay, but my transmission is shifting okay, sortof hard downshifting sometimes but i believe thats the flex discs.

and im just curious on hesitation because ive noticed that sometimes it will downshift and upshift GENTLY, that you dont even feel it, when lightly depressing the accelerator to maintain speed????? and if the solinoid has gone bad? is it replaceable or time to replace transmission??? (again) haha
 
1 - 3 of 3 Posts
Top