Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
99' 230slk Sport
Joined
·
98 Posts
Discussion Starter #1
took car out of storage 2 weeks ago. CEL has been on for the last week. I found the time to work on the car. So I had stopped at auto zone and got the car scanned. What do you know P0170...Looked around at all the posts (MAF). I cleaned it ..though it did not seem too dirty or oily like I've read. I put back it in. CEL still for a day and a half and the car seemed the same for the most part. But then checked the air filter and Yuck..very dirty. Changed it out with a new one took it for a ride and believe it or not ...wow. I actually felt a difference. I drove maybe 10 miles pulled up to my house and the CEL went out. I'm hoping I should be good..time will tell.

Just figured I'd share my story about a very aggravating light looking at you. Seems the filter is very important also.
 

·
Registered
Golf R32 / Prev R170 SLK
Joined
·
6,821 Posts
took car out of storage 2 weeks ago. CEL has been on for the last week. I found the time to work on the car. So I had stopped at auto zone and got the car scanned. What do you know P0170...Looked around at all the posts (MAF). I cleaned it ..though it did not seem too dirty or oily like I've read. I put back it in. CEL still for a day and a half and the car seemed the same for the most part. But then checked the air filter and Yuck..very dirty. Changed it out with a new one took it for a ride and believe it or not ...wow. I actually felt a difference. I drove maybe 10 miles pulled up to my house and the CEL went out. I'm hoping I should be good..time will tell.

Just figured I'd share my story about a very aggravating light looking at you. Seems the filter is very important also.[/QUOT E]

I always assume peeps check the easy things 1st :(
 
1 - 2 of 2 Posts
Top