Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
I already posted here once with my issues, i thought that i would post again since i got no replies and if no one replies again then i get the message but here is where i am at with my problems, this is also posted on mbworld

p0100 Mass or Volume Air Flow A Circuit
p0135 O2 sensor Circuit bank 1/1
p0130 O2 sensor Heater Bank 1/1

So those are the codes after scanning...
I assume the first is for the MAF and the second ones i know are for the 02 sensor, but i have been having a problem with 1st gear, i will explain...

the symptoms
- Dragging feeling through the pedal when flooring it from a stand still
- pulsing, stuttering, jittering when sitting at lights on start up and in the rain, but after about 15 minutes on a nice day it goes away
- K&Ns put in but i just ordered a new maf and filters from MB and will put them in later and hopefully solve the problem.
- I also had an independant shop suggest either the kickdown sensor or electronic acceleration sensor

I order the kickdown sensor and was told by Euro that no one has ever ordered before but it wasn't much so i went ahead and got that too.

The acceleration sensor though i was told would be above 700 dollars and i really can't afford that espicially if that isn't going to fix my problem.

Conclusion...
I'm going to replace the MAF, Filters, Kickdown sensor, Tranny Fluid, Diff fluid and gasket,

Already have done service B, spark plugs(don't know if they were included in service b but i did them), Vacuum Hoses and valve cover gaskets.

It's very upsetting to leave a 206k mi 97 M3 because i was scared it was getting to old and would just become a drain on my bank account but this amg has cost me more in the last 3 weeks since i bought it then the m3 did in a 6 month period....

any help is appreciated.
-greg
 

·
Registered
Joined
·
483 Posts
how long have you had the car? What year? What is the mileage? Did it have records?

Did you have a full Pre purchase inspection? Im guessing not.

Sounds like you have been taken sir.

MAF can explain alot of problems. If youd search you will find not only do K and Ns do noting for power for this car the oil gets on the film of the MAF and causes it to fail.

I wouldnt do business with this indy they sound like they are taking advantage of you rather than troubleshooting to find the problem.

I think your cats are starting to fail. Clogged Cats can make the car surge, buck, and pulse. When mine went the car would surge like a manual tranny car when you stomp on it and let off. Down hill it would buck and raise the rpms unusually high like its trying to shift to second but cant, but it was just the clogged cats restricting the exhaust flow.

Try the MAF first.

If that dsent fix it. I would bet you are looking at replacing 1 or 2 of the 4 cats. If the substrated brakes off youll hear it sounds tinny and it rattles bad. but for a while mine substrate was intact, it was just clogged by bad fuel. NEVER use less than the highest grade in this car.

What happens when its in park and you rev the engine, do the rpms come down fast or slow?

ANDY
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
I have had the car for about 4 weeks now, it's a 2001 with 90k on it but i put in 4k since i have bought it. The car had no records but the carfax was clean and i did have a pre purchase inspection, (The carfax said it had been taken in to a MB Dealer for it's servicing up till it was just sold to the dealership i bought it from). I changed the MAF and the air filters back to oem, it is running fine now, but the problem with the accerleration is still there.
 

·
Registered
Joined
·
414 Posts
did you have the dealer reset all of the adaptations on the car? Trans especially? Once this is done you need to re-train the car for a few hundred miles. Any record of a trans service being done while you're there? What about fuel filter, that will kill the car, especially if never changed.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
No one reset any computers for me and can't i do that myself? with the key in and foot on the accel pedal? I'm doing a trans fluid flush this week and i already ordered the fuel filter.

I feel that when the pedal is floored i can push it further so that it clicks and then the revs jump up and picks up real fast. is that normal?
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
No one reset any computers for me and can't i do that myself? with the key in and foot on the accel pedal? I'm doing a trans fluid flush this week and i already ordered the fuel filter.

I feel that when the pedal is floored i can push it further so that it clicks and then the revs jump up and picks up real fast. is that normal?
Yes its normal and its called kick down, when you push the pedal to the floor the transmission automatically goes to a lower gear and the revs will increase and subsequently your car will move faster
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
So there should be a click because when i floor it, it moves but when i floor and push it a little bit harder and it clicks it really moves. If so thats great!
 
1 - 7 of 7 Posts
Top