Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hello all!

My car has been having the high idle issue in the P and N gears and I decided to check if it was my OVP fuse. The OVP fuse is intact but when I pulled the relay out, it sounded like something was broken inside because if I shook it, it would rattle. I was just wondering if this was normal? Any help would be greatly appreciated! Thank you all.
 

·
Registered
Joined
·
4,012 Posts
Hello all!

My car has been having the high idle issue in the P and N gears and I decided to check if it was my OVP fuse. The OVP fuse is intact but when I pulled the relay out, it sounded like something was broken inside because if I shook it, it would rattle. I was just wondering if this was normal? Any help would be greatly appreciated! Thank you all.
That _alone_ doesn't mean that it's bad. There is a sheet of insulation under the printed circuit board that can rattle.
 

·
Registered
Joined
·
1,895 Posts
Sure doesn't sound right to me... I'd be looking to replace it. Do you have access to a known good one?
 

·
Registered
Joined
·
388 Posts
my 380SL has the same problem with high idle. It is driving me crazy. I tried replacing almost everything including the rattling OVP fuse and didn't do anything. I hope that is your problem. What is the part number on the OVP fuse? I might have a good one, no rattling. I am in San Jose, PM me.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
Hello all!

Thank you for your replies!
To strife-It rattles a lot! Do you think the foil would make that much noise?

To joconab- I am sorry to hear that, have you fixed your high idle problem yet? I will get back to you this weekend because I am not currently near my car right now (out of town).

P.s. Does your car only have high idle in the P and N gears?
 
1 - 5 of 5 Posts
Top