Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
i was driving my benz ml350 2008 and suddenly check engine sign turned on. my parents are eager to take it to the dealer and it may cost money to check whats going on and the place wont open till monday and i have work tomorrow. but before i do that, did anyone else here encounter the same problem?? and how was it fix??? please!! i need answers!! how do i check my codes??
 

·
Registered
E320/E250 Bluetec Ford F350 6.7l
Joined
·
36,729 Posts
CEL usually is triggered by emmision or engine management system. Usually you can drive with it for a while but not knowing what it is you are taking your chances. Might be loose gas cap, or bad MAF sensor. Check the codes to learn more what is it.
 

·
Registered
Joined
·
1,328 Posts
i was driving my benz ml350 2008 and suddenly check engine sign turned on. my parents are eager to take it to the dealer and it may cost money to check whats going on and the place wont open till monday and i have work tomorrow. but before i do that, did anyone else here encounter the same problem?? and how was it fix??? please!! i need answers!! how do i check my codes??
Don't worry too much it's still under warranty :) Just in case there is a problem with your emission system (which is unlikely) , they have to replace it.
Probably a loose gas cap. When you have the CEL reset, the next time you're filling up, make sure to turn the gas cap a few times; you should hear 3 clicks. ;)
 

·
Registered
2006 S500 4Matic
Joined
·
177 Posts
+1 on checking the gas cap. Once I put the cap on but did not close it until it clicked and the Check Engine light came on. Tightened the cap and the light went off (can't remember if it was instantly or just quickly). The fuel system expects a tight seal and if that doesn't exist, the warning light comes on.
 

·
Registered
'04 Black CL500, "06 White ML350, '98 Red Boxster
Joined
·
124 Posts
I had an 06 ML350 and I filled the car while it was running once.....

The check engine light took 5-6 restarts to go away for me as well.
 
1 - 7 of 7 Posts
Top