Mercedes-Benz Forum banner

1 - 20 of 67 Posts

·
Registered
1994 S500 Sedan
Joined
·
1,214 Posts
Discussion Starter #1
The last time I brought my car to the shop it was running extremely rough and the engine wiring harness was replaced. Since then I've noticed that the oil pressure gauge has been very erratic. I brought it back to the shop and was told it's the oil sender switch, but got a call a couple of days later and mechanic said I also need an oil sender / ignition wiring harness, as he sees that the wires are exposed (as had happened with my engine wiring harness). At first he said he believes the part to be $150, then he called back to say the dealer is saying $350!?

Some questions:

1. Is the wiring harness in reference coated in soybean oil (as with engine wiring harness), and is it prone to failure (in the same way, with time)?
2. Are there cheaper alternatives than the dealer (mechanic says he hasn’t seen aftermarket harnesses)?
3. I know it's been discussed before, but with this new info, could this harness relate to the odometer not working?

Thanks!
 

·
Registered
1995 S500 coupe, 1990 Mazda Miata
Joined
·
694 Posts
The replacement harnesses are not prone to the same failure as they come with updated insulation. The price sounds about right as a discounted price for my '95 coupe was $275 from the dealer.
 

·
Premium Member
1997 S600 (sold)
Joined
·
4,660 Posts
Yes that harness, which is sometimes called the lower engine harness around here, degrades like the upper harness. It includes wires feeding the starter. Replace it.

Some have rebuilt it themselves with new wiring.

I don't think there would be a connection to your odometer. Do you still have the analog odometer in your cluster? Many of these have been replaced with digital odometer clusters due to failure.

Brett
 

·
Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,886 Posts
The alternator light on the dash, the oil pressure light, oil level, and the alternator output, are part of this harness. The starter is also part of this harnes, and is not available on the secondary market. I got my education by first of all a lazy altenator light depending on the temperature, which I could not duplicate then I took it to the dealer for intermittent oil level and oil pressure indicator and a leakinfg fuel line. The typical MB response was "bad oil pressure switch", then "bad oil level sensor", resulting pan leak since they had to drop pan and then wanted to replace pan. This did not solve the issue, It had a bad lower harness.
This is just an example of mechanic padding the clock, they are no longer technicians, just parts changers. I have not used the new dealeship again, since this is not the first issue, they replaced a steering box and wanted to replace the pump I did the box and a hose no leak. They also put dino in instead of synth, and I dont know why dist caps go bad in a year, they replaced those as customer adjust. These dealerships are owned by the same conglomerate.
 

·
Premium Member
84 500 SEL ...94 S420..... 95 S500.... 96 S500 95 S600
Joined
·
1,705 Posts
Lower Harness

I paid $135.00 at Wholesale cost in Ma. It was for a 94 S420, I think its the same as a S500..Just sayin!!
 

·
Registered
1995 S 420, 2012 GLK 350 and 1997 Audi Cabrio; Previously 1982 280CE, 1974 450SL, 1974 911S Targa
Joined
·
456 Posts
I paid $135.00 at Wholesale cost in Ma. It was for a 94 S420, I think its the same as a S500..Just sayin!!
Hey Eddie!

What was the part number and..do you have the website for the wholesaler in MA? Oh...would '94 and '95 be the same?

Thanks!!!
 

·
Registered
1994 S500 Sedan
Joined
·
1,214 Posts
Discussion Starter #7
Thanks 95S, Brett, Peter and Eddie; all solid contributors to this board!

I cannot believe what's taking my indy so long, as days go by and my calls go unreturned, but I got through to him today and he said he's going to repair the harness and all should be fine.

Car will supposedly be ready tomorrow; I'll post the results when I have them.
 

·
Registered
1995 S500 coupe, 1990 Mazda Miata
Joined
·
694 Posts
Hopefully the bill will be less than $400 as a new harness installed should be about that. Yes I wish I had a V12. May things go well with you :)
 

·
Premium Member
1997 S600 (sold)
Joined
·
4,660 Posts
I would recommend finding out just exactly what he is proposing to do to repair the harness. Is he just wrapping a couple of wires with electrical tape? Just splicing in a short length of new wire in the middle of where there is some visible degradation?

In my opinion, given this harness' exposure to engine heat and the elements along its entire length, anything short of replacing every wire from connector to connector (full rebuild from pin to pin with opening up the connectors) is not an acceptable repair of the harness at this point.

Brett
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,639 Posts

·
Registered
1994 S500 Sedan
Joined
·
1,214 Posts
Discussion Starter #11
Picked up my car today. Indy repaired the wiring harness and replaced the oil sender. But now my yellow oil warning light is lit on the instrument cluster. Indy said he doesn’t know why the light is on, but that it may be the cluster that has gone bad(!?). He said that when the lower wiring harness was in bad shape, the light may not have been lit because the wiring for the oil level may have been getting a positive connection and it was keeping the light off, but now that the wiring is fixed, there must be something wrong with the instrument cluster. DOES THIS MAKE ANY SENSE? Could the instrument cluster have been damaged from badly crossed wiring, making the instrument cluster think the oil level was fine!?!? I AM SO PISSED. If that's true, why hasn't more than one warning light gone bad? Any insight, anyone? It's just upsetting becuase I somehow trust this guy and know he knows what he's doing (old timer Polish guy who works strictly on late 90's and earlier Mercedes, rebuilds engines, transmissions, etc.), so I don't see why he would lie, but come on - I bring my car in for one thing and he returns it with another problem (like that of my odometer not working, for which he's saying is the cluster as well, EVEN THOUGH IT WAS WORKING PRIOR!?!?). NOT HAPPY.
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,639 Posts
Well he's got it wrong ,you need the oil warning sender that is inside the oilpan ( i forgot the name of that sender ),mine did exactly the same thing when my harness was bad ,even after replacing it that yelow oil warning light was still on ,not to see it i took out the bulb behind the cluster temporarily .If you want a picture of that plug let me know . :thumbsup:
 

·
Registered
1994 S500 Sedan
Joined
·
1,214 Posts
Discussion Starter #13
Thank you for your prompt reply.

Is this something I can fix myself?

If so, yes, please post pics, etc., as I'd like to get this light off ASAP.
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,639 Posts
Here you go , its called oil warning sender and you need to take the oilpan of , I did have a diagram/schematic here somewhere of the exact location ,if i find it i post it here for you . :thumbsup:
 

Attachments

·
Registered
1994 S500 Sedan
Joined
·
1,214 Posts
Discussion Starter #15
Thanks!

Question: Was you yellow oil light on before your wiring harness repair? Mine was not.
 

·
Premium Member
84 500 SEL ...94 S420..... 95 S500.... 96 S500 95 S600
Joined
·
1,705 Posts
I would recommend finding out just exactly what he is proposing to do to repair the harness. Is he just wrapping a couple of wires with electrical tape? Just splicing in a short length of new wire in the middle of where there is some visible degradation?

In my opinion, given this harness' exposure to engine heat and the elements along its entire length, anything short of replacing every wire from connector to connector (full rebuild from pin to pin with opening up the connectors) is not an acceptable repair of the harness at this point.

Brett
Ill second this!!
 

·
Premium Member
84 500 SEL ...94 S420..... 95 S500.... 96 S500 95 S600
Joined
·
1,705 Posts
Hey Eddie!

What was the part number and..do you have the website for the wholesaler in MA? Oh...would '94 and '95 be the same?

Thanks!!!
I have an account at a dealer in Ma. Ill get it for you if you need me to, let me know, Ill need year and model and V.I.N. of the vehical...
 

·
Premium Member
84 500 SEL ...94 S420..... 95 S500.... 96 S500 95 S600
Joined
·
1,705 Posts
Wait! I think that's what was replaced! The oil sender.
The sender MercS500 has shown is the oil level sensor ( I think ) I know the oil preasure sendor is located on the oil filter housing.. Which connects to the lower harness..
 
1 - 20 of 67 Posts
Top