Mercedes-Benz Forum banner
1 - 3 of 3 Posts

·
Registered
1991 560 SEL
Joined
·
260 Posts
Discussion Starter · #1 ·
Since my oil pressure had dropped to scary levels, I decided to change out the pump. I did it Saturday, and what an easy job. If you have any worries about pressure, and a new sending unit doesn't fix it, don't be afraid to change the pump. All you do is drop the lower pan, take off the two bolts that connect the oil level sending unit, remove the 3 bolts that hold the pump,and take off the gear on the front. You can't change the chain without taking off the front of engine, but its a short chain,and it should be okay. I was worried that I might have bad main and/or rod bearings, but now my pressure is like new.
 

·
Registered
Joined
·
7 Posts
I am curious. What is the actual improvement that you gained by replacing your old pump with a new one, and what was the 'scary level' that you had before? Do you now get a constantly pegged 3 bar reading, or is it still low at idle when the engine has reached operating temperature?

When I had at first not visually inspected the ~$250 OEM part, but was experiencing gradually subsiding oil pressure on test runs in my W126 (above idle speed), I figured that it might be an electrical pump, which was getting tired. Once I opened the oil pan, I saw that it's a mechanical pump, however, and further inspecting it's innards, did not reveal any parts that should wear excessively considering that it's one of the components benefiting from oil the most in the lubrication system, since it's closest to the source. If memory serves me right, there are only two gears inside of the pump that are actually responsible for creating the oil flow.

I ended up cleaning the pick-up filter and serviced the pressure relief valve, which had become sticky. I know have a pegged indicator @ cruise speeds, and 1.0-1.5 @ idle speed.

What type of oil pressure improvements did you experience with the new pump?

Glad to hear that there are enough users on this board that are not afraid to DIY, instead of adding substantial labor fees to the purchase cost of relatively expensive parts (relative to domestic brands).
 

·
Registered
90 420SEL
Joined
·
44 Posts
Glad to hear it!My 420 has 102,000mi and have never seen it go below 2.3 bar yet at idle.Hope it doesn't.
I've only had it a little over a month and didn't get any records with it, so I'm going to have to go through it good, before any long road trips.
 
1 - 3 of 3 Posts
Top