Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,301 Posts
Yep - pretty minimal - tighten bolts and clean down and see what happens (I had one of these on a C class -much worse and thought I had a head gasket problem!) just cleaned it down every yr.

Bazzle did a post on renewing the seal I think - Get the right sealant

Oil filter O ring - worth undoing and checking (renew)



Oberoi
 

·
Registered
Joined
·
441 Posts
Found a oil leak, it looks like its been there for some time. There is no oil on the ground, just on the block. I did notice that the o ring for the oil filter cap is sticking out between the bottom of the cap and the houseing for the filter. Could this be the source? or is it from another place?? There seems to be more sludge than oil.
If ther's oil all over filter cap, then yes.
Make sure you clean everything after you fix this and check it more often, because on the second picture it looks like camshaft magnet is leaking.
Mine leaked right from the socket, so I had to replace it. It costs around $50.

Good luck
 

·
Registered
Joined
·
1,006 Posts
Check that camshaft magnet, round thing in bottom pic. So many of us have experienced a leak here. I bought a new one and swapped it out easy (3 screws) - no more leak!
 

·
Registered
Joined
·
377 Posts

·
Registered
Joined
·
5,368 Posts
That's a common problem with MB. On their newer motor, the M271 they use in the C230, when the cam sensors leak, the connector is on the bottom so it goes into the wiring harness, clever so you don't get messy oil everywhere. Then the oil finds it's way to the O2 sensor (the lowest point on the harness) and walla, $2,000 repair bill for a new harness, new O2 sensors and new cam sensors.
 
1 - 7 of 7 Posts
Top