Mercedes-Benz Forum banner
1 - 4 of 4 Posts

·
Registered
Love the 560 SEL
Joined
·
26 Posts
Discussion Starter · #1 · (Edited)
I'm going to go look at a '91 560SEL that has a minor oil leak, would that sway your judgement in buying the car? I know this might be a blank question but I haven't seen the car yet and don't know where it is coming from. What should I look for and where is it? I'm just looking to get your opinion again! I forgot to tell you he said the way he noticed it was a couple of drips in his garage or driveway. Also the ABS and SRS lights are lit up on the dashboard.
 

·
Registered
1990 Mecedes-Benz 420SEL
Joined
·
1,217 Posts
Sure, Longhorn, it matters where the leak is. First, make sure you know what kind of fluid it is (transmission, engine, coolant, power steereing, hydraulic from the suspension?). This will help you narrow it down. Could be something as simple as a valve cover gasket. Although I wonder why an owner would not fix a minor leak before selling the car, you will want to have a mechanic perform a pre-purchase inspection anyway.

ABS and SRS lights are more serious, as you will definitely want to know what the electrical problem is. Search the forum on the ABS light.

How many miles?

Would sure like to see a fellow Texan who loves the 560SEL find a nice one, but wait for the right car. I found mine, a Texas car, with only 53,000 miles, and it is probably the nicest W126 in the state (respectfully to any other Texas members).

Dave
 

·
Registered
Love the 560 SEL
Joined
·
26 Posts
Discussion Starter · #3 ·
It has about 135k. I'll check for sure but the guy didn't really know too much about it (the leak). Yeah I've been searching far and for over 6 months now but no go. I read the "before buying guide" and it has been really helpful. I also have to give a lot of appreciation to Bruce, he is really knowledgable and just a great guy. As you can see I'm not in a big rush but wonder if it will ever happen. :)
 

·
Registered
1988 Mercedes 300SE
Joined
·
61 Posts
I have an SRS liight on my 300SE, and I'm told by the mechanic that it is likely a sensor under the passenger side dash. $400+ for a new one, but I've got one on the way from a junk yard for 30 bux. ABS? I dunno. Maybe trouble with that expensive module on the left front fender? The bigger question: sounds like somebody may have left a few things go to pot with the intent of finding someone not as well informed as yourself. One or two things...on these damned cars, always, but if it's a number of problems...pass. These things will eat your lunch.

Don
 
1 - 4 of 4 Posts
Top