Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter #1
Well I changed the distributor cap and rotor, also did the poly V-belt at the same time. Well since then, my ABS light has come on as well as a nasty, almost ratting sound when I accelerate to 3000 rpms. Idle is perfect except for this sound. sounds like metal clanking against medal. wtf could I have done doing only these minor repairs?
One more thing, fluids are all good. It seems to be running hot as well, but not enough to freak out.
 

·
Registered
Joined
·
1,545 Posts
yeah, absolutely. Went by the picture in the manual.
How does the belt now feel since you drove it, still as tight as you left it? Did you in your excitement ( guilty ) forget to tighten the Belt Tightener Lock Bolt? I forgot and I took out the tightener rubber in under 5 miles. Though the Power Steering pump should have let you know when cranked the belt is loose.

Running Hot - mmmm Are you really sure you ran the belt correctly. I don't even know IF there is a wrong way that would actually tighten up but... Everything turning, Alt, Water pump, A/c, Power Steering. Now don't shoot me.. is the belt inside out maybe? Grooves in the grooves? Grasping at straws here. No idea what would cause the ABS light to come on that has anything to do with a belt except maybe the Alt not working???? Wild quess.

Have you got to 3k sitting there while you look or only when driving.

If you're not sure where noises are coming from, a poor mans ( cheap works ) mechanics stethoscope is a 3 or 4 ft pc of vinyl tubing, 3/4 or 1" ID , put one end to an ear and move the other end around. Works good, you can even hear just the bearing in the Alternator if you want.

Dan
 

·
Premium Member
Joined
·
2,354 Posts
Well I changed the distributor cap and rotor, also did the poly V-belt at the same time. Well since then, my ABS light has come on as well as a nasty, almost ratting sound when I accelerate to 3000 rpms. Idle is perfect except for this sound. sounds like metal clanking against medal. wtf could I have done doing only these minor repairs?
One more thing, fluids are all good. It seems to be running hot as well, but not enough to freak out.
Check your power steering pump.
 

·
Registered
Joined
·
407 Posts
Discussion Starter #6 (Edited)
I'm thinking it has something to do with the distr./ rotor because it started making noise after I put the new stuff in. I don't think it has anything to do with the belt. I'm debating taking the new stuff out and putting back in the old stuff to see if it still does it.
 

·
Registered
Joined
·
4,949 Posts
I'm thinking it has something to do with the distr./ rotor because it started making noise after I put the new stuff in. I don't think it has anything to do with the belt. I'm debating taking the new stuff out and putting back in the old stuff to see if it still does it.
Then do it, it won't take you 5 mins.
 
1 - 7 of 7 Posts
Top