Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter #1 (Edited)
OEM LED tail lights NOT plug and play

*** i have edited the original subject for future searchibility ***

hey gang, so I recently put on OEM led tails from an ML63 on my 09 ML350, and everything was plug and play.

however, just the other day I saw another ML with them, presumably from factory. I noticed that it was not lit up the same way, or rather mine were lit up in a way that this other vehicle was not.



the red lines are obviously LED brake lights.
the yellow lines are LED turn signal lights
the green is incandescent bulb reverse light

so what's the blue line for??

these are also incandescent bulbs, and they are lit on mine whenever the headlights are on, but on this other car they were not. can someone with an 09+ ML with the lighting package from factory take a look and tell me 1) if the lights are always on and 2) if not, when they do come on?

thanks in advance
 

·
Registered
2010 ML550 Palladium Silver, Black MBTex, P1, Lighting pkg, Trailer Hitch.
Joined
·
96 Posts
on my 2010:

Top 3 rows (1, 2, 3) are Brake lights. ONLY these 3 rows (not rows 7 & 9 like you indicate.)

Agreed about the yellow arrows (turn signal) and green arrow (Reverse)

Rows 1, 3, 7, 9 are regular lights (headlights) and are also the parking lights.

The mysterious blue arrow (row 8) is the rear fog light and it illuminates on the driver (left) side only.

Or graphically...

:mad: Brake and headlight
:mad: Brake
:mad: Brake and headlight
:) Indicator
:surrender: Reverse
:) Indicator
:eek: headlight
:confused: Fog
:eek: headlight
 

·
Registered
Joined
·
106 Posts
Discussion Starter #4
excellent, thank you!

you are right about the brake lights only being at the top.

it looks like i need to swap pins around as the fog lights are always on, on both sides, and i've been thinking perhaps rows 7 and 9 are not lit up at all. hard to say, since the whole lower half looks lit up, due to the fogs being on.

i really appreciate the time taken to look and reply :beerchugr:

graphic diagram was especially top notch :rotfl:
 

·
Registered
Joined
·
106 Posts
Discussion Starter #5
upon close inspection, everything lights up and works as intended, with the exception of the rear fog lights, which are constantly lit on both sides.

as bruntoj said, only the driver side rear fog light should be on, and then only when activated. the passenger side bulbs are superfluous, as there is no instance when they should ever be lit. i guess they are spare bulb holders :p

i had this corrected yesterday via star diag when bringing the ML in for the bi-annual brake flush, and it took about 5 minutes to recode the rear SAM module. i could not have corrected this on my own without SDS.

so, contrary to the info out there, these lights are not plug and play for ANY model year owner.

bruntoj, thank you again
 
1 - 7 of 7 Posts
Top