Mercedes-Benz Forum banner
1 - 11 of 11 Posts

·
Registered
1984 500SEL EuroSpec w/ an AMG steering wheel : ).
Joined
·
223 Posts
Discussion Starter · #1 ·
I have been through three different cluster panels, and none of them have working odometers. I do not think that this is a coincidence. Could a problem exist else where?
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,498 Posts
The drive gear strips teeth when the mileage is changed when vehicle is moving. New gears are available. Google Mercedes Benz Speedometer Gears. The place is in Virginia and will next day air new gears for about S65.00 USD.
Easy fix if you follow the directions given with the gears.
 

·
Registered
1984 500SEL EuroSpec w/ an AMG steering wheel : ).
Joined
·
223 Posts
Discussion Starter · #3 ·
Thank you, although I have a new cluster panel. Also, the green teeth are connecting well with the black teeth (Looking at the back of the odometer). Where does the electrical wire lead to that plugs into the back of the odometer?
 

·
Premium Member
2012 CL550 4MATIC Coupe - RIP
Joined
·
10,014 Posts
I would beg to differ.

The Speedo/Odo is an all electronic affair. Does the Speedo turn and just the ODO is out?

What was the source of the Speedo/Odo clusters? Same car type? (ie: 126?)

I have a spare cluster I can send you that is known good and I can check it in my car prior to shipment if you like.
 

·
Premium Member
2012 CL550 4MATIC Coupe - RIP
Joined
·
10,014 Posts
I can send you the SM's. PM Sent
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,498 Posts
The Speedometer/odometer is electric, but the odometer drive gear(little one) strips the gears off of one of the two big gears when zeroed while moving after 20 some years of age makes the once pliable gears brittle, even if one tooth is gone the little gear will not turn the odmeter and sometimes one tooth is very hard to see. When you move the odemter gear by hand you can see one gear NOT moving. If neither speedometer or odometer are registering then it's probably the sender.
 

·
Registered
1984 500SEL EuroSpec w/ an AMG steering wheel : ).
Joined
·
223 Posts
Discussion Starter · #7 ·
I would beg to differ.

The Speedo/Odo is an all electronic affair. Does the Speedo turn and just the ODO is out?

What was the source of the Speedo/Odo clusters? Same car type? (ie: 126?)

I have a spare cluster I can send you that is known good and I can check it in my car prior to shipment if you like.

The speedometer does work. The trip and odometer count is out. I had received the odometer from my Grandad's storage. He had bought it years ago, but never installed it. I noticed that my old odometer had an 8 pin connection coming from the green circuit board. This new Cluster Panel only has 6 pins coming from the green circuit board, and an extra 2 prong plug called an EZL connect... I do not have a connection for this. I'm thinking that the unit might be incompatible.

I have a 1984 Euro 500SEL. Thank you very much for the service zip files! I will check into them for sure.
 

·
Premium Member
2012 CL550 4MATIC Coupe - RIP
Joined
·
10,014 Posts
Yes, I have the Gen I unit like you need.

To give Charlie his due, he may be correct, however, if you do not have the correct cluster in, that is probably the source of your troubles. I will look in the schematics again.
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,498 Posts
Yep! if the pin count is different, then you do not have the correct cluster. That may be your problem.

I believe that if the speedo IS working and odometer isn't then it is almost certainly the gears. If it were the sensor then neither would work.

I just put new gears in my 1984 Euro 500SEC speedometer cluster and that was what was wrong. the Black (I think) gear had one or two teeth sheared off and gone, but of course the small gear was setting in the gap and could not make a connection to the big gear. Really easy fix with the new gears and instructions provided. In fact I bought the whole set, but only needed one gear, as the others were in great shape.
 

·
Registered
2005 SLK350, 91 300SL with Pano Top, 04 S500, 2015 Tesla Model S
Joined
·
2,136 Posts
The gear slips on the shaft. It is an easy repair as long as you don't spill the whole mess. I used a drill bit to slide the shaft out and then gave the shaft a few well placed smacks with a small hammer. This flattened the shaft ever so slightly to grip the gear. The arrrow points to the slipping gear.
 

Attachments

1 - 11 of 11 Posts
Top