Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
1991 500 sl 118000 mls my odometer is not reading mileage the speedometer still works has anyone had this problem?? I,m new to this car.
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,004 Posts
You have a mechanical odometer, so may be some gears are worn out.
 

·
Registered
SL500 1990, USA specification. Chassis No. WDB FA66E5 LF 005675
Joined
·
47 Posts
A common problem also is gear teeth strip from tiny plastic gears inside the speedo head. New gears can be purchased (replace both at the same time) from Jeff Caplan at Odometer Gears | 72 Croatan Road | Newport News, VA 23606 | 757.593.3478
Actual unit looks like the pix in this thread: http://www.benzworld.org/forums/r129-sl-class/1351712-odometer-not-working-1990-sl500.html
Full procedure goes like a similar thread produced for volvo: http://www.matthewsvolvosite.com/odometer_fix.php (at least,both white plastic gears appear identical).
If this is first time for taking out the instrument cluster - recommend pushing it from behind, rather than only pulling using tools from either side.
Fix takes about two hours - and motion of read-out wheels may be a tad jerky as the new teeth settle in (see Jeff's note about spinning the dials before full re-assembly).
Good luck.
Ali D-C.
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,371 Posts
Had exactly that on my SEL chanced the gears and it works.
It will help if we know what part of the world you are, so I can give you
more info.
Regards.
aam.
 
1 - 4 of 4 Posts
Top