Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
2001 e320 wagon
Joined
·
36 Posts
Discussion Starter #1
i have a 2001 e320 wagon (78K miles), and i bought it with a problem [xx(]. on the odometer cluster, the temp display/compass and the clock displays do not work. just the center display works, the ones on the left and right do not work.

do i need to replace the whole cluster, are there any bulbs or fuses that will fix this problem?

any ideas? anyone else have the same problem? i'll try to post a few pics so you can see.
 

Attachments

·
Registered
10 GLK 350 4Matic
Joined
·
704 Posts
I'm used to seeing, and I have[:(!] problems with occasional pixel failures - haven't seen a complete display failure like this, but what's interesting is all the other complaints your car is giving.

You have "Check Engine" and the "Major Failure" alert both going. They may be related, but until you get connected to a diagnostic reader the errors may be elusive.

Are you getting specific malfunction alerts in the center ( working) display?
 

·
Registered
SLK320, MKV Jetta TDI, Mini Cooper S, Lincoln Mark LT
Joined
·
1,712 Posts
I would pull the cluster out and check the bulbs first. It looks like the numbers are being displayed but there is no back light to iluminate them.
 

·
Registered
Joined
·
262 Posts
definitely a Pixel failure, not a simple bulb failure...lots of newer BMWs are also plagued with this issue...i know a company in Santa Ana ,Ca that fixes this issue(specifically from BMWs- not sure about MBs though). im guessing they can fix this for you....run a google search for Instrument Cluster Pixel repair(i cant remember their contact info.
 

·
Registered
2001 e320 wagon
Joined
·
36 Posts
Discussion Starter #5
mjhawkins2346 - 2/20/2005 4:35 PM

I'm used to seeing, and I have[:(!] problems with occasional pixel failures - haven't seen a complete display failure like this, but what's interesting is all the other complaints your car is giving.

You have "Check Engine" and the "Major Failure" alert both going. They may be related, but until you get connected to a diagnostic reader the errors may be elusive.

Are you getting specific malfunction alerts in the center ( working) display?
mike,

my bad - the check engine light and the warning light are lit because the engine was off when the pic was taken, but the key was in the ignition. no other problems. engine runs strong.
 

·
Registered
2001 e320 wagon
Joined
·
36 Posts
Discussion Starter #6
how do i pull out the cluster?

if i do need another cluster, do you know what it costs?

thanks,
mark
 

·
Registered
10 GLK 350 4Matic
Joined
·
704 Posts
The cluster is just a friction fit in the opening.

It has been covered in previous posts, however, there is a tool ( pair) available at the dealership or eBay that can help with the removal. They look like T-handles with a thin wire-like shaft about 10 inches long and a small "L" or hook at the bottom.

They slip down the sides and hook on the cluster from the back to help you slip it out.

Good luck.
 
1 - 7 of 7 Posts
Top