Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
HI all, my first time posting and I guess I have come to a point where I really do need some help. I have a W203 2003 C Class Coupe C180k Auto, since I have purchased this car (6 months ago) I have had a few issues, at the moment, I have a few outstanding ones which I am hoping maybe someone can help point me in the right direction?

I noticed that the MPG has always been around the 20mpg for city driving, I am not exactly a harsh driver and was expecting something more around the 26/7mpg range. I have invested in a ODBII reader which gave me a few codes, at the moment the engine managment light is on and shows code P0171 which means Fuel Trim too rich (bank 1) or System too Lean (Bank 1) depending on where you look, from my research it seems that this could be one of the following:

1) faulty or dirty air mass flow sensor
2) vaccum leak
3) o2 sensor

I have previously taken this to a garage and was told to have my o2sensor checked although the garage didn't seem too confident that was the actual problem.

So I thought lets try cleaning the MAF first using this stuff here:

CRC AIR SENSOR CLEAN MASS AIR FLOW CLEANER MAF UK STOCK on eBay (end time 13-Dec-10 17:51:46 GMT) (ebay MAF Cleaner)

problem is, I have no idea where the MAF is, I have taken a few pictures of the engine, maybe someone can point me in the right direction?









I can tell that the car is losing power as well as wasting more fuel than maybe it should be...

To make matters worse, I now seem to be getting white smoke coming out of the exhaust, I thought this was condensation from the catalytic converter at first but looking at other cars, no one else is having this problem, there was never any smoke from my car before..

Help!

Thanks in advance!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Hi guys, just an update to this as I have finally found some time to do this, unfortunately, it was something like 2degrees Celsius outside!

Anyway, this actually took me 2 attempts as I didn't have the correct tool. Found out reading up in the other thread that you don't need an E10 invert, instead just use a 8mm Hex socket piece, which i noticed it sooner!

Anyway, followed the tutorial and eventually (had to hacksaw/ rip out with long nose pliers the tube part). I check the actual $12 hose and it actually seemed fine, i took off the close part and no problems, i used my fingers to feel around the other part and from what I could see seemed ok although not 100% as i couldn't get my fingers in :(

Also, I was trying to clean the MAF as I bought some CRC Maf cleaner, but I just couldn't for the life of it work out how to get it off? It seemed to be connected in the back/bottom to some sort of pipe. I wasn't sure how to take it off or put it back on so I left it. Any advice on this?

Also, what if I was to clean that MAF section from inside the air throttle box (where the air filter is)? Would that be safe? It would be a hell of a lot easier?

I tell you what I did find dodgy was the large grey pipe that connects to the air throttle box, i have used aluminium foil to stick it back down with lots of layers to reinforce it. Unfortunately, I was forced into buying some premium oil (regular out of stock) which doesn't really give me a good indication of whether this has been fixed or not.

I have attached pics of this

I have noticed that the white smoke coming from the exhaust is still quite bad

I have uploaded the video onto imageshack as follows:

http://img163.imageshack.us/img163/9897/sa8.mp4

Any advise guys?

Thanks in advance!
 

Attachments

·
Registered
06' C230 Sport
Joined
·
19 Posts
great post! seems like u got it all figured out. although, im not so sure about the whole tin foil thing on a MB.

have you noticed any improvements on fuel economy and/or power?

Thanks!
 
1 - 3 of 3 Posts
Top