Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
1988 Mercedes 560SL
Joined
·
40 Posts
Discussion Starter #1
After receiving my 88 560SL Ebay "bargain" last year I have attempted to do my own repairs and troubleshooting on the one major issue using this forum and the rest of the Web for guidance. The issue was difficult cold starts and stalling until a short warm up period. This was coupled with a gas smell in the cab. This was a low milage 77K card that had sit for 10 years. The major gas smell was caused by a broken nipple on the fuel pressure regulator that the dealer had siliconed together. I replaced the part with no more smell but no improvement. Replaced the accumulator with a slight improvement. Last month I noticed gas at the base of my throttle body and discovered it was leaking from the EHA valve. The EHA is a simple replacement and the car fires up and runs perfectly now. It also fixed an odd symptom that the car would stall if left out on damp days. It also fixed an inconsistent idle Praise the Web.
 

·
Premium Member
1984 380SL, 1973 450SLC
Joined
·
2,174 Posts
these things are so easy to repair and maintain,, even a caveman can do it..:D
 

·
R/C107 Moderator
1986 560SL: '84 500SL: '84 280SL 5 speed: other 107s
Joined
·
32,354 Posts
Good job. Thanks for reporting your repairs.
 

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,512 Posts

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,512 Posts
Can we make fun of typing? Man I miss ussun.:(
Absolutely.

But maybe he spelled it like an East Bloc accent.



Yes........Ussun was the best at the werst spelink.
 
1 - 13 of 13 Posts
Top