Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Mercedes W163 270CDI 2000
Joined
·
17 Posts
Discussion Starter #1
Hi

I have a Mercedes ML 270 from 2000, which has been driven 227 000km (141 000 miles) The car has been in Norway during all these years.

The problem I am experiencing is that the front driverside brake activates Even if my foot is not on the brake pedal. It happens most when I turn left, but it also happens when I drive straight ahead at low speed. It sounds like the ABS, traction or ESP thinks something needs to be corrected. When tid happens there are no light in the ESP, traction, ABS warning light. And the light that flashes when you skid or spinn does not light up when the brake decides to activate

Luckily the brake is not applied with force, but it makes me a bit scared to drive the car.

The sensor at the front driverside wheel, and the cables from it has been checked by an official Mercedes shop, and another Mercedes shop says it light be the ESP unit that might be the problem. This part is really expensive in Norway, so they want to search some more before they replace it. Is This a common problem, or have someone experienced this problem too?
 

·
Registered
Mercedes W163 270CDI 2000
Joined
·
17 Posts
Discussion Starter #3
Hi, and thanks for the quick reply.

The BAS/EPS lights do work, because I unhooked the power cable while doing something with the carstereo. After I hooked the power on, the three lights came on, and disapeared right after I turned the wheel from side to side.
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,105 Posts
Hi, and thanks for the quick reply.

The BAS/EPS lights do work, because I unhooked the power cable while doing something with the carstereo. After I hooked the power on, the three lights came on, and disapeared right after I turned the wheel from side to side.
That might be all well and good, but that would have nothing to do with your problem of the brakes locking up.

The next time the event occurs, you must have the code/s read immediately. Do not clear the codes.
 

·
Registered
Mercedes W163 270CDI 2000
Joined
·
17 Posts
Discussion Starter #5
Ah yes, the codes.

This summer when the first Mercedes shop looked at my car, they found out that the event that triggered the lights looked like there was something wrong with the cable from the front driverside abs cable. They checked the connection on the ABS sensor, and they checked the cable running from it. But they found nothing wrong with it.
 

·
Registered
Mercedes W163 270CDI 2000
Joined
·
17 Posts
Discussion Starter #6
Update: When I started the car today, all the brake warning lights lit like a x-mas tree.

I am going to take the car to a shop tomorrow and see what codes it comes back with.
 
1 - 6 of 6 Posts
Top