Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1979 450SL
Joined
·
3 Posts
Discussion Starter #1
I have a 1979 450SL with 61K on it.

Since I'm still becoming familiar with these cars (just bought this one January '03---first SL), I'm trying to figure out what "normal" is. For instance, the temperature runs from a little over half (about 190-200 degrees, which seems fine) all way towards the 3/4 mark (212 degrees, by my estimation). And sometimes it will even go above the 3/4 mark (approx 220+ degrees) if it is shut down and restarted quickly. That seems a little high to me, but maybe it's normal.

The car has had the radiator replaced, a new coolant reservoir and a new thermostat. It did overheat once (in 2000), so the head gaskets have been replaced, along with all kinds of other related work.

Since I live in Arizona, the heat is a concern to me, but like I said, maybe these cars just run a little hot.

Also, this engine really retains heat, I've noticed. It seems to take 10-12 hours (at least) to cool completely. Again, is this normal for the 4.5 liter V8?

Thanks,

GJC
 

·
Registered
1979 450 SLC
Joined
·
1 Posts
i can relate

I too just purchased a 1979 450 slc back in NOvember. The first day i was stuck in traffic, i noticed it was idling really high, too. I got scared, pulled over and let the car rest. the next day i took it to my mechanic to check it out. He said there is nothing wrong with the car, and it's okay for the tempature to get into that 3/4 area. i still get queasy when it starts to rise, but so far i have not had it overheat.i don't know if that helps. I am starting to think this is all normal for this car.

i always find when i start it up first thing, there is no problem. BUT when i go to use the car later, the car takes a while for the car to "click int". my mechanic cannot find anything wrong iwth it. And, my friend(whom i bought the car from and collects classic cars) said he could not figure it out either. Do you have this problem ?
i am trying to figure it out. it's gotta be something.

thanks
LMC
 

·
Registered
1979 450SL
Joined
·
3 Posts
Discussion Starter #3
LMC-

Thanks for the response. I am fairly certain that the car is fine, even with the h...


LMC-

Thanks for the response. I am fairly certain that the car is fine, even with the high temps sometimes in traffic. I've been told by the local MBZ dealer that the 3/4 temp. range is normal in traffic/heat conditions.

As for the other problem, I assume you mean it starts slowly after running and then restarting while the engine is still warm? If so, then yes, my car does this too. I just had some fuel system work done at the dealer(to correct a cold/hot start problem), but the slow starting when warm still remains. If I figure it out, I'll post something.

Thanks,
GjC
 
1 - 3 of 3 Posts
Top