Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Mercedes S500L W220
Joined
·
268 Posts
Discussion Starter · #1 ·
:mad:

Hello everyone,

I have a 2000 S500L. Drives ok and had it 2 months. The engine has developed a ticking noise. It sounds like (pardon my amateur engine knowledge) the pistons are catching on something as they turn. Have been told by someone that its something to do with hydraulic 'taps' inside the engine. I've had the oil changed and use V power fuel. The mileage is 140,000miles. High? I don't know, what do you think? I mean they are 5.0 V8 mercedes engines!

Are there any other common problems that I should be aware that may happen in the near future?

Thanking you all.

:thumbsup:
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
I know on the W140's engine at those high miles they can develop whats called a hydraulic lifter tappet problem. Basicly the device that feeds the oil down the engine block has become noisy. My understanding is that it still lets the oil flow but is just noisy. I'd say best to get it replaced.
 

·
Registered
2000 S430
Joined
·
105 Posts
I use only full synthetic oil ( Mobil1 0W40) and when 4000 miles is up I always run Liqui Moly Motorspulung (part number 2427)thru the engine B4 old oil drain . It is the only Engine flush formulated for high preformace engines and it is tested by TUV availible here in USA .
When I look in my engine with borescope it looks like its brand new.
Never use any oil additives ...
 

·
Registered
My Benz: 04 S430
Joined
·
1,219 Posts
Bad catalytic convertors will also make a knockind sound that sounds just like lifters or lower end knock.. have them checked..
 

·
Registered
Mercedes S500L W220
Joined
·
268 Posts
Discussion Starter · #6 ·
ARGH!!!! forgot to mention im from rainy britain and my 2000 S500L is a W220!!!!!!!
 
1 - 6 of 6 Posts
Top