Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1997 w140 s500, 1990 renault 5 gt turbo
Joined
·
8 Posts
Discussion Starter · #1 ·
hi

just bought ,a 97 s500, with 120k on it, and now its started ticking !
been reading up on how the oil guides are plastic , and break over time .

so i took off the right side cam cover , where the ticking was coming from , and checked all the plastic guides and chain guide ,and they where all in very good condition as where all the gaskets .
put it all back together ,so put some noisey tappet oil additive in ,and let the engine run for a bit, but still the noise was there!

any one else with this problem here?

not sure if it is a valve stem on the way out ?

lewis
 

·
Registered
1997 S 500
Joined
·
89 Posts
I expect you've been following a recent thread I began:

http://www.benzworld.org/forums/w140-s-class/1374172-engine-ticking-tappet-noise.html

In addition to verifying that the cam oilers/tubes/tappets are intact, it's critical to ensure that they're also unobstructed. Make sure nothing is blocking the tubes internally.

Also, how confident are you you've identified the correct side? I thought I had this nailed down too, but mine was making noise from both sides. Awfully hard to pinpoint in that noisy engine compartment.

good luck,
Mike
 

·
Registered
1997 w140 s500, 1990 renault 5 gt turbo
Joined
·
8 Posts
Discussion Starter · #4 ·
hi mike,

the ticking definatly comes from the right side ,nearer the back i think ,(drivers side in the UK ) ,its more louder when i stand near the drivers door!!?
well u could be right , some could be blocked , as i only took two of the guides out to inspect them ,and blew through them fine. maybe i should take them all out and see!
or maybe put some engine flush in before i change the oil?cleen every thing out?
if i cant fix it ill just take it to a merc garage ,and see what they say ,once and for all!!!
as its starting to do my head in!!!
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
It could be a noisy injector.. so before you go spending the folding, Get a long extension bar or a long screwdriver, put it on the engine near the noise and listen..if its a tappett it will be louder near the inlet or exhaust if not drop the injectors off one at a time, it will run like a dog but you might find the one, hope this helps, dont put flush in till you know the problem..
 

·
Registered
W639 Vito 110 CDI; Ponton 220S; VW Phaeton V10 tdi; 1995 S500 ex diplomatic car (gone)
Joined
·
574 Posts
Hydraulic tappets can gum up with age. Remove the tappets and soak in cellulose thinners overnight and flush, works on other engines. 4 cams, 32 lifters........

I'm not advocating this, but it has worked before.
 

·
Registered
1997 w140 s500, 1990 renault 5 gt turbo
Joined
·
8 Posts
Discussion Starter · #7 ·
cheers guys , ill try the injectors on my next day off!
ill let u know how i got on!

lewis
 
1 - 7 of 7 Posts
Top