Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
E-Class 320 cdi
Joined
·
5 Posts
Discussion Starter #1
Hi, I can hear a "clonk" coming from the front right hand side when reversing and turning the steering. It happens when the car has been parked for a while. Overnight, for example. If I try to simulate it, it won't happen till the car has been parked for a while. The car is a w211 e320cdi. 2003. Any suggestions will be greatly appreciated as it's driving me crazy.

Regards.
Eddie
 

·
Registered
Current 2008 320ML CDI. Previous 1998 E320, 2007 E320 Bluetec
Joined
·
2,507 Posts
Brake pads are shifting. Might be good to look at the brakes and confirm they are seated properly.

Skippy


Sent from my iPad using Tapatalk
 

·
Registered
E-Class 320 cdi
Joined
·
5 Posts
Discussion Starter #3
Brake pads are shifting. Might be good to look at the brakes and confirm they are seated properly.

Skippy


Sent from my iPad using Tapatalk
Thanks for that. I'll give it a try though it doesn't seem as if it's coming from there. I think it's a bit further up. I've recently replaced everything that there is to replace, I think, from suspension struts to tie rods going through all the front axle parts. It only happened, again I think, when I changed the Spring Control Arms and the Tie Rods. Do you think I should go through the process of loosening and then tightening all nuts available?

Thanks again for your advice and prompt response.

Regards.

Eddie.
 

·
Registered
Current 2008 320ML CDI. Previous 1998 E320, 2007 E320 Bluetec
Joined
·
2,507 Posts
It’s always useful to re-examine previous work when chasing a problem.
Car drives OK?


Sent from my iPad using Tapatalk
 

·
Registered
E-Class 320 cdi
Joined
·
5 Posts
Discussion Starter #5
It’s always useful to re-examine previous work when chasing a problem.
Car drives OK?


Sent from my iPad using Tapatalk
Sorry for the delay. The car drives fine except for a bit of shaking of steering wheel between 100 - 120 Kmh. I think balancing of front wheels is due. To-morrow Saturday I'll be doing the re-tightening of all nuts and bolts that I've replaced and see what the outcome is. Thanks for your suggestion. I'll report back.

Regards.

Eddie.
 

·
Registered
E-Class 320 cdi
Joined
·
5 Posts
Discussion Starter #6
Hi there,
I re-tightened all the nuts and bolts as mentioned before and everything is now fine. No noise. I first of all loosened everything with the tyres on, therefore allowing the full weight of the car, before tightening. I'll be taking the car to-day to a specialist to do wheel balancing and that should be it. Fingers crossed.

Regards.

Eddie.
 
1 - 6 of 6 Posts
Top